0

I recently got an alienware 14 laptop, and want to use Linux on it. I installed Ubuntu 14.04. However, I found that the wireless adapter does not work - Killer Wireless-n/a/ac 1525 Wireless Network Adapter.

So I purchased usb wifi adapter. Now I can connect to Wifi, but extremely unstable. After I have been connected for about 5 minutes, it still says connected, but cannot use internet. I tried to ping a random address, there is simply no echo, rather than no response - nothing echoes in my terminal. If I disable wifi and enable again, sometimes it will connect for another 5 minutes, sometimes just fails to connect.

I thought it was a problem of the usb wifi adapter, so bought another one for raspberry pi, but exactly the same problem.

I thought it was a problem of my Linux distribution, so I tried Ubuntu 12.04, Linux Mint, Fedora 23. All have the same problem.

Still cannot use WiFi on Linux, on my ALienware 14 laptop. Feeling frustrated. Anyone could help? Thanks.

Results of lspci -knn | grep Net -A2:

    03:00.0 Network controller [0280]: Qualcomm Atheros Device [168c:003e] (rev 20)
    Subsystem: Bigfoot Networks, Inc. Device [1a56:1525]
    04:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5227 PCI Express Card Reader [10ec:5227] (rev 01)
    Subsystem: Dell Device [1028:0685]

marked as duplicate by Pilot6, Community Nov 13 '15 at 15:41

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Please edit your question and add output of lspci -knn | grep Net -A2 terminal command. – Pilot6 Nov 13 '15 at 15:12
  • Not sure, maybe not. Since this is not a problem with Ubuntu. Fedora or Linux Mint does not work either. – Quan Nov 13 '15 at 15:23
  • All distributions need the same kernel module and hardware. Just install it. – Pilot6 Nov 13 '15 at 15:24
  • And it's not no wifi at all. It just fails after a few minutes. – Quan Nov 13 '15 at 15:24
  • Tried, but seems cannot get it: – Quan Nov 13 '15 at 15:25
0

This adapter is supported by the 4.2 kernel. You can install in to Ubuntu 14.04 by running

sudo apt-get install linux-generic-lts-wily

Then reboot. You will need to have an updated firmware too. You can install the updated one by

sudo apt-get install linux-firmware

If that firmware does not enable the adapter, then install firmware from Ubuntu 15.10

wget http://mirrors.kernel.org/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.149.2_all.deb
sudo dpkg -i linux-firmware_1.149.2_all.deb
  • The fireware from Ubuntu 15.10 works! Thanks so so much! – Quan Nov 13 '15 at 15:35
  • I updated the other answer too. – Pilot6 Nov 13 '15 at 15:39

Not the answer you're looking for? Browse other questions tagged or ask your own question.