1

I have an old Macbook from the year 2006, (Intel CPU)
The OS (Mac OS X 10.6.8) suddenly stoped working, not sure why...
So I decided to use a Ubuntu Live Boot (USB), (The CD Reader is dead) to boot and I backup up the entire disk:
I used used an ethernet cable to conect to another computer, which has Ubuntu installed (Willy Werewolf) then I used LinkLocalOnly for the network conection,
Then using sshfs I mounted a folder of the other drive to the local desktop.
Then I used gnome-disks to Create Disk Image of the entire Hard Drive, and set the output location for the file to the mounted folder, (so it would port/pipe it directly to the other PC)
When done it said Error reading 21 MB, they have been replaced with zeros, but the rest of the 320 GB Hard Drive was Backed up.

Afterwards I permanently installed Ubuntu 15.10 (Willy Werewolf) repartitioning the entire disk, probably killing some data, after which I began installing software, Wine, VLC, Steam, Java, and more it worked fine, a bit slow, but it booted atleast, a few installations later and a couple reboots, it started booting SLOW 5+ minutes of the purple starting screen, but without the Ubnutu logo, then it started working. I was getting slightly worried, a couple reboots later, it spent 30+ minutes booting, I was getting very worried, then another reboot later it did not boot all it did was 5 minutes of black screen, then a black screen with the text: error: failure reading sector X from 'hd0'. but then X was replaced by a hexadecimal number: 0x2542eaa0 for example it pumped out a few more defect sectors, including 0x0, after a while of doing that it went to a grub Command-Line User Interface,

I restored the Disk Image I talked about earlier, using the USB Live Boot, and sshfs + gnome-disks again, it still won't boot the original OS (OS X 10.6.8)
And some data has been corupted if it was a program or an app or some downloads, I'd say, well that sucks, BUT no, it doesn't see the bytes that identify the Users directory. I booted it with the Ubuntu Live Boot, and tried with fsck but it threw the following error: Pastebin

I have no clue how I could get it back now, so please if you have an idea, please respond, thank you! Have a nice day!

P.s. mac os x would not boot anymore BUT the data was still intact

  • it looks like your harddisk was already broken with Mac OS X on it... – DJCrashdummy Nov 13 '15 at 15:17
  • mac os x would not boot anymore BUT the data was still intact – sjaak31367 Nov 14 '15 at 10:51
1

it looks like your harddisk was already (at least partly) broken with mac os x on it, then you created an "also broken" image of it. with using it further you completely killed the harddisk.

if there are usable data within the image, with a other working machine or live system (with support for reading HFS+ filesystem) you can maybe read some remaining data from the image by...

  • using tsk_recover (package sleuthkit) to read files on the fly from your image
  • mounting (mount) your image direct and look after your files
  • or writing it via dd to a new/other harddisk and then connect as a normal external media

if all methods don't give you some data IMHO the last thing you can try is, after mounting or writing the image to a harddisk, using photorec (testdisk) to recover them... but it is unlikely that in this case it will do the trick! :-/

  • 1
    Thank you very very much!!! I was able to get most if not all important data back with photorec (testdisk) thank you very very VERY much! – sjaak31367 Dec 6 '15 at 12:35
  • 1
    P.s. I tried tsk_recover it only gave a bunch of emtpy folders and 19KB of text files. Mounting it didn't show any files in the corrupter user directory. And I tried dd but with no the same result as mounting. also you don't have to mount it for photorec just put the image file as input in the command – sjaak31367 Dec 6 '15 at 12:39

protected by Community Dec 29 '15 at 15:57

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.