0

I have spent the evening trying to get xrdp working...

None of these ~/.xsession options work - the connection starts, but then crashes

gnome-session -–session=Ubuntu-2d
gnome-session -–session=gnome-fallback

This question is similer: 14.04.3 xrdp "gnome-session --session=ubuntu-2d" not Work But has no answer.

I have found a solution, using xfce4 instead of gnome, but I would prefer not to have to use two different shells for one system.

Is there any gnome session that does work?

1

This is a known issue with xrdp and Ubuntu. If you want to use xrdp with Ubuntu 12.10 and later, you will need to install an alternative desktop environment. the ubuntu-2d does not exists anymore and the gnome-fallback has also some issues.

The best option so far is to install an alternative shell. You can install mate-desktop interface (which look like the gnome 2 interface)

so to summarize:

Step 1 - install xrdp

sudo apt-get install xrdp 

Step 2 - Install mate-desktop

sudo apt-get update
sudo apt-get install mate-core mate-desktop-environment mate-notification-daemon

Step 3 - the .xsession file should contain mate-session

Full instructions for Ubuntu 15.10 can be found here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.