I installed ubuntu server 14.04 LTS on a virtual machine (vmware, win host). The VM has internet access (given a port-id, adaptertype E1000E and a MAC). Sadly ubuntu was not able to detect the device automatically.

ifconfig -a shows only the loop back interface but lspci prints the following Ethernet controller:

0b:00.0 Ethernet controller: Intel Corporation 82574L Gigabit Network Connection

How can create a proper eth0 interface?

The /etc/network/interfaces file contains only a lo interface so I tried to create a eth0. The VM-Host provided a the IP, net mask, gateway settings. So I added the following lines to my /etc/network/interfaces:

auto eth0
iface eth0 inet static
address ....
gateway ....
netmask ....

Then I tried to force these settings by calling /etc/init.d/networking restart but without success.

The devices uses the e1000e Kernel-Module. I already tried to remove and load it again, but I always get the error, that it's busy.

UPDATE: The network settings for the vm look like this:

enter image description here

So there is no network connection, but the device status is connected. I used Windows on the same VM before and there the internet connection worked out-of-the-box. How can access such a network connection with ubuntu?

  • All commands in var/log/boot.log pass with status [OK]
  • cat /var/log/syslog | grep -i eth is empty
  • dmesg | grep -i etc is also empty


It seems like the e1000e interface support is not quite good, so I asked the vm-admin to change the interface type to vmxnet3. Now the ifconfig -a returns two different interfaces (lo and a new ens192).

dmesg | grep vmxnet3

enter image description here

Then I added the following lines to my /etc/network/interfaces:

auto ens192
iface ens192 inet static
    address x.x.x.x
    netmask x.x.x.x
    network x.x.x.x
    broadcast x.x.x.x
    dns-nameservers x.x.x.x
    dns-search example.com
    gateway x.x.x.x

... and restarted the service per /etc/init.d/networking restart. But the interface is not connected:

ping google.com



return "Destination Host unreachable"

  • check "cat /etc/udev/rules.d/70-persistent-net.rules"
    – PKumar
    Nov 13, 2015 at 11:31
  • @PKumar this file does not exists. There is only a README within /etc/udev/rules.d/.
    – NaN
    Nov 13, 2015 at 11:36
  • ok no issue, try to run "ifconfig eth0 up" then check "ifconfig -a"
    – PKumar
    Nov 13, 2015 at 11:38
  • As I mentioned earlier, there is no eth0 (just the loopback interface) so the command returns "eth0: ERROR while getting interface flags: No such device".
    – NaN
    Nov 13, 2015 at 12:01
  • 3
    Hi Nan, could you please remove the solution from the question and add it as (accepted) answer.
    – bummi
    Nov 21, 2017 at 7:21

1 Answer 1


Use e1000 on Ubuntu. Neither vmxnet3 or e1000e are fully supported or work well with NAT*

(*)at least for OP


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .