1

Hello I am running Ubuntu 14.4 LTS (`3.13.0-68-generic #111-Ubuntu x86_64 x86_64 x86_64 GNU/Linux') and I am one of the many who experience palm detection / too high sensitivity with the touchpad, sending the cursor around while typing.

I have already found many advice by reading around (there are many posts, I quote a few References below), and tested some solutions, but I have not yet achieved a solution which continues to work after reboot.

In particular I have already followed those present on AskUbuntu and StackExchage (see references below) about "how to correct this and that syndaemon setting".

All those I have read basically reduce to the following two steps:

  1. play around with syndaemon settings until you are satisfied

    --> and this works fine, e.g. with commands /usr/bin/syndaemon -i 0.5 -d -K, but only until the end of the session

  2. put a proper line in "Startup Activities" (whatever it's named, in Italian it is "Applicazioni d'Avvio") so that it will be automatically done for future sessions. For this I also took into account that it needs a prepended sleep, in order to run when all the required process background is properly setup. the full line is: /bin/bash -c "sleep 10&&/usr/bin/syndaemon -i 0.5 -d -K"

Even doing so, I still experience those issues again, and when I inspect the syndaemon process by means of htop or ps -ax | grep syndaemon, I find:

2005 ?        S      0:04 syndaemon -i 1.0 -t -K -R
2224 ?        Ss     0:04 /usr/bin/syndaemon -i 0.5 -d -K

See the unwanted line is still there (it's the first). What does it mean Ss in the second line?

What can I do to fix it once and forever (and for all users?)

PS. On every user account where I have made such tests changes, there also happen the following side-effect: from time to time the touchpad goes inactive, in such a way that I cannot toggle it on by pressing Fn+F5. Rather it needs a synclient TouchPadOff=0 to revive.

That's all. I thought I would find more complete information by asking the forum directly.

A few References:

[syndaemon] Where to configure syndaemon settings?

[retain] How to make touchpad settings stick on Ubuntu 14.04.1 (Trusty)

0

You have two instances of syndaemon running. That can cause cursor lockups, etc.

One of the instances could be started by checking "Disable while typing" in system settings. You need to disable it if you use another command.

| improve this answer | |
  • How can I update the command in "startup activities" so to kill the unwanted instance, while at the same time launching the new one? – lurix66 Nov 13 '15 at 17:32
  • You need just uncheck the setting in System Settings -> Mouse – Pilot6 Nov 13 '15 at 18:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.