2

I had installed Kubuntu 15.04 sometime ago. I upgraded to 15.10, things were going fine till I added ubuntu-desktop to use Unity DE.

When booting with systemd, on startup or login, I get black or white screen for all Virtual Terminamls (TV's / TTY's) including TV7 graphical one. In some rare cases flickering screen between lightdm & sddm GUI, and that's how I got to know that both were running and may be the cause of this problem (black screen).

It works fine: when booting with upstart or switching DM back to sddm.

  • Flickering screen between KDE/sddm Unity/lightdm

    https://youtu.be/xI1fpTyklNo
    https://youtu.be/HpH309GqFcU

  • ps ax | grep dm

     1377 ?        SLsl   0:00 /usr/sbin/lightdm
     1459 tty7     Ssl+   1:10 /usr/bin/X -core :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
     1526 ?        Ssl    0:00 /usr/bin/sddm
     1626 ?        SLl    0:00 lightdm --session-child 12 19
     3843 pts/2    S+     0:00 grep --color=auto dm
    
  • systemctl status default.target

    ● graphical.target - Graphical Interface
       Loaded: loaded (/lib/systemd/system/graphical.target; static; vendor preset: enabled)
       Active: active since Fri 2015-11-13 09:46:21 CET; 50min ago
         Docs: man:systemd.special(7)
    
    Nov 13 09:46:21 BlueSkies systemd[1]: Reached target Graphical Interface.
    
  • sudo dpkg-reconfigure lightdm

    Default display manager:
        gdm
      * lightdm
        sddm
        xdm
    
  • ls -l /etc/systemd/system/display-manager.service

    lrwxrwxrwx 1 root root 35 Nov 13 17:26 /etc/systemd/system/display-manager.service -> /lib/systemd/system/lightdm.service
    

I don't want to remove any DM, also I do want to keep LightDM as default. So, is there a canonical answer to How to set the default DM for this mixed release 15.10 (systemd/upstart)?

I could find many similar question without the answer I'm looking for:

  • Hi, my answer is not relevant to this question. The problem was caused by the i810 drivers not being correctly loaded into the initrd. This has been solved in 15.10 (kernels in the 4.x series). Your problem on the other hand is not relevant to drivers issues (in my opinion) but to multiple login managers beind started. – Palantir Nov 15 '15 at 16:56
  • @Palantir Yep, definitely your answer is not related but that behavior with lightdm is the same. Could you check the you still have blank screen on login (with no VT too) when using lightdm (instead of sddm)? – user.dz Nov 16 '15 at 9:34
  • 1
    We've been using full disk encryption on Kubuntu install at work ever since it came out years ago. No issues... – dargaud Nov 17 '15 at 18:33
4

I end up adding a ExecStartPre line to check for default display manager on legacy settings /etc/X11/default-display-manager, now it's working well:

/lib/systemd/system/sddm.service

[Unit]
Description=Simple Desktop Display Manager
Documentation=man:sddm(1) man:sddm.conf(5)
After=systemd-user-sessions.service getty@tty1.service plymouth-quit.service

[Service]
ExecStartPre=/bin/sh -c '[ "$(basename $(cat /etc/X11/default-display-manager 2>/dev/null))" = "sddm" ]'
ExecStart=/usr/bin/sddm
Restart=always
#PrivateTmp=yes

[Install]
Alias=display-manager.service
WantedBy=graphical.target

Reference: Copied from /lib/systemd/system/lightdm.service

I'm not familiar with systemd, so no idea why sddm was started on boot. I have gdm too, it does not start by itself.

Update: I Could find a related bug report

  • 1
    Just reported this upstream, referenced now in LP-bug. – ellisistfroh Apr 9 '16 at 13:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.