I'm having some strange graphical issue with windows manager in Kubuntu 14.04 LTS.

Some time after I'm using the system i notice some artifacts that affects windows. I'm attaching some examples

This make the system unusable: for example if I click on a icon in Dolphin the icons of the "parent" folder does not disappear and overlaps with the icons of the folder I just clicked.

I wasn't able to isolate what causes this behaviour: when I start the system it works just fine, then after some time happens what is shown in the images.

Edit: This issue happened again, I noticed it when the pc was running for 3 hours. Thanks ellisistfroh, I launched on a terminal the commands that you suggested. It does not look like a Xorg problem. I don't think is an overheating problem because if I logout/login the problem disappears. I also tried to restart KWin but with no success.

$ egrep "EE|WW" /var/log/Xorg.*
/var/log/Xorg.0.log:    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
/var/log/Xorg.0.log:[     5.756] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
/var/log/Xorg.0.log:[     5.756] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
/var/log/Xorg.0.log:[     5.756] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
/var/log/Xorg.0.log:[     5.756] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
/var/log/Xorg.0.log:[     5.756] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
/var/log/Xorg.0.log:[     5.758] Initializing built-in extension MIT-SCREEN-SAVER
/var/log/Xorg.0.log:[     5.774] (WW) Falling back to old probe method for modesetting
/var/log/Xorg.0.log:[     5.774] (WW) Falling back to old probe method for fbdev
/var/log/Xorg.0.log:[     5.774] (WW) Falling back to old probe method for vesa
/var/log/Xorg.0.log:[   221.844] (WW) EDID timing clock 328.32 exceeds claimed max 145MHz, fixing
/var/log/Xorg.0.log.old:        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
/var/log/Xorg.0.log.old:[  1541.546] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
/var/log/Xorg.0.log.old:[  1541.546] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
/var/log/Xorg.0.log.old:[  1541.547] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
/var/log/Xorg.0.log.old:[  1541.547] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
/var/log/Xorg.0.log.old:[  1541.547] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
/var/log/Xorg.0.log.old:[  1541.549] Initializing built-in extension MIT-SCREEN-SAVER
/var/log/Xorg.0.log.old:[  1541.553] (WW) Falling back to old probe method for modesetting
/var/log/Xorg.0.log.old:[  1541.553] (WW) Falling back to old probe method for fbdev
/var/log/Xorg.0.log.old:[  1541.553] (WW) Falling back to old probe method for vesa
/var/log/Xorg.0.log.old:[  1550.426] (WW) EDID timing clock 328.32 exceeds claimed max 145MHz, fixing
/var/log/Xorg.0.log.old:[  6081.944] (EE) Server terminated successfully (0). Closing log file.

$ lspci -nnk | grep -iA2 vga
00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)
        Subsystem: Samsung Electronics Co Ltd Device [144d:c0d7]
        Kernel driver in use: i915

$ tail -n 50 ~/.xsession-errors
Script for none started at run_im.
Script for auto started at run_im.
Script for default started at run_im.

Edit2: I didn't specified that the GPU is an HD3000 (Intel integrated) Other info

$ java -version
java version "1.7.0_85"
OpenJDK Runtime Environment (IcedTea 2.6.1) (7u85-2.6.1-5ubuntu0.14.04.1)
OpenJDK 64-Bit Server VM (build 24.85-b03, mixed mode)

$ uname -a
Linux mypc 3.13.0-68-generic #111-Ubuntu SMP Fri Nov 6 18:17:06 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

$ dpkg-query -l xserver-xorg-core* | grep ^ii
ii  xserver-xorg-core                     2:1.15.1-0ubuntu2.7 

$ dpkg-query -l *-lts-* | grep ^ii
(No info)

$ qdbus org.kde.kwin /KWin supportInformation
KWin Support Information:
The following information should be used when requesting support on e.g. http://forum.kde.org.
It provides information about the currently running instance, which options are used,
what OpenGL driver and which effects are running.
Please post the information provided underneath this introductory text to a paste bin service
like http://paste.kde.org instead of pasting into support threads.


KWin version: 4.11.11
KDE SC version (runtime): 4.13.3
KDE SC version (compile): 4.13.2
Qt Version: 4.8.6

focusPolicy: 0
nextFocusPrefersMouse: false
clickRaise: true
autoRaise: false
autoRaiseInterval: 0
delayFocusInterval: 0
shadeHover: false
shadeHoverInterval: 250
separateScreenFocus: false
placement: 4
focusPolicyIsReasonable: true
borderSnapZone: 10
windowSnapZone: 10
centerSnapZone: 0
snapOnlyWhenOverlapping: false
showDesktopIsMinimizeAll: false
rollOverDesktops: true
focusStealingPreventionLevel: 1
legacyFullscreenSupport: false
commandActiveTitlebar1: 0
commandActiveTitlebar2: 30
commandActiveTitlebar3: 2
commandInactiveTitlebar1: 4
commandInactiveTitlebar2: 30
commandInactiveTitlebar3: 2
commandWindow1: 7
commandWindow2: 8
commandWindow3: 8
commandWindowWheel: 31
commandAll1: 10
commandAll2: 3
commandAll3: 14
keyCmdAllModKey: 16777251
showGeometryTip: false
condensedTitle: false
electricBorderMaximize: true
electricBorderTiling: true
electricBorderCornerRatio: 0.25
borderlessMaximizedWindows: false
killPingTimeout: 5000
hideUtilityWindowsForInactive: true
inactiveTabsSkipTaskbar: false
autogroupSimilarWindows: false
autogroupInForeground: true
compositingMode: 1
useCompositing: true
compositingInitialized: true
hiddenPreviews: 1
unredirectFullscreen: false
glSmoothScale: 2
colorCorrected: false
xrenderSmoothScale: false
maxFpsInterval: 16666666
refreshRate: 0
vBlankTime: 6000000
glDirect: true
glStrictBinding: false
glStrictBindingFollowsDriver: true
glLegacy: false
glCoreProfile: false
glPreferBufferSwap: 101

Screen Edges
desktopSwitching: false
desktopSwitchingMovingClients: false
timeThreshold: 150
reActivateThreshold: 350
actionTopLeft: 0
actionTop: 0
actionTopRight: 0
actionRight: 0
actionBottomRight: 0
actionBottom: 0
actionBottomLeft: 0
actionLeft: 0

Multi-Head: no
Active screen follows mouse:  no
Number of Screens: 2
Screen 0 Geometry: 0,0,1366x768
Screen 1 Geometry: 1366,0,1280x1024

Current Plugin: kwin3_oxygen
Shadows: yes
Alpha: yes
Announces Alpha: yes
Tabbing: yes
Frame Overlap: no
Blur Behind: no

Qt Graphics System: raster
Compositing is active
Compositing Type: OpenGL
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile 
OpenGL version string: 3.0 Mesa 10.1.3
OpenGL shading language version string: 1.30
Driver: Intel
GPU class: IvyBridge
OpenGL version: 3.0
GLSL version: 1.30
Mesa version: 10.1.3
X server version: 1.15.1
Linux kernel version: 3.13
Direct rendering: yes
Requires strict binding: no
GLSL shaders:  yes
Texture NPOT support:  yes
Virtual Machine:  no
OpenGL 2 Shaders are used
Painting blocks for vertical retrace:  no

Loaded Effects:

Currently Active Effects:

Effect Settings:
zoomFactor: 1.2
mousePointer: 0
mouseTracking: 0
enableFocusTracking: false
followFocus: true
focusDelay: 350
moveFactor: 20
targetZoom: 1

fadeInTime: 250
fadeOutTime: 250





zoomDuration: 300
border: 10
desktopNameAlignment: 0
layoutMode: 0
customLayoutRows: 2
usePresentWindows: true







layoutMode: 0
showCaptions: true
showIcons: true
doNotCloseWindows: false
ignoreMinimized: false
accuracy: 20
fillGaps: true
fadeDuration: 150
showPanel: false
leftButtonWindow: 1
rightButtonWindow: 2
middleButtonWindow: 0
leftButtonDesktop: 2
middleButtonDesktop: 0
rightButtonDesktop: 0
dragToClose: false

blurRadius: 12
cacheTexture: true

useBlur: true

brightness: 0.5
saturation: 0.5
blur: false




Edit 3: As suggested by @ellisfroth I installed openjdk-6. I was experiencing this issue this morning and the problem solved without rebooting.

$ sudo apt-get install openjdk-6-jre-headless openjdk-6-jre  openjdk-6-jdk

$ dpkg-query -l openjdk-* | grep ^ii
ii  openjdk-6-jdk:amd64                   6b36-1.13.8-0ubuntu1~14.04              amd64        OpenJDK Development Kit (JDK)
ii  openjdk-6-jre:amd64                   6b36-1.13.8-0ubuntu1~14.04              amd64        OpenJDK Java runtime, using Hotspot JIT
ii  openjdk-6-jre-headless:amd64          6b36-1.13.8-0ubuntu1~14.04              amd64        OpenJDK Java runtime, using Hotspot JIT (headless)
ii  openjdk-6-jre-lib                     6b36-1.13.8-0ubuntu1~14.04              all          OpenJDK Java runtime (architecture independent libraries)
ii  openjdk-7-jdk:amd64                   7u85-2.6.1-5ubuntu0.14.04.1             amd64        OpenJDK Development Kit (JDK)
ii  openjdk-7-jre:amd64                   7u85-2.6.1-5ubuntu0.14.04.1             amd64        OpenJDK Java runtime, using Hotspot JIT
ii  openjdk-7-jre-headless:amd64          7u85-2.6.1-5ubuntu0.14.04.1             amd64        OpenJDK Java runtime, using Hotspot JIT (headless)

$ dpkg-query -l icedtea* | grep ^ii
ii  icedtea-6-jre-cacao:amd64             6b36-1.13.8-0ubuntu1~14.04              amd64        Alternative JVM for OpenJDK, using Cacao
ii  icedtea-6-jre-jamvm:amd64             6b36-1.13.8-0ubuntu1~14.04              amd64        Alternative JVM for OpenJDK, using JamVM
ii  icedtea-7-jre-jamvm:amd64             7u85-2.6.1-5ubuntu0.14.04.1             amd64        Alternative JVM for OpenJDK, using JamVM
ii  icedtea-netx:amd64                    1.5-1ubuntu1                            amd64        NetX - implementation of the Java Network Launching Protocol (JNLP)
ii  icedtea-netx-common                   1.5-1ubuntu1                            all          NetX - implementation of the Java Network Launching Protocol (JNLP)
  • 1
    would be useful to me to know why this has been downvoted so I can improve questions I will do in the future. Thanks Nov 15, 2015 at 9:22
  • Not sure why it was downvoted, but I don't think it deserved it. By any chance do you use Chrome? I'm experiencing a simlar thing in GNOME, only when using Chrome. Might be unrelated though.
    – kos
    Nov 17, 2015 at 19:46
  • @kos Yes i use chrome, version 46.0.2490.86. When the problem happens chrome is opened, but has been opened for a while, not when I first open chrome. The browser is the first thing I open after the Terminal :D Nov 18, 2015 at 12:48

2 Answers 2


Could as well be this bug (see also bug-duplicates there):

https://bugs.launchpad.net/debian/+source/openjdk-7/+bug/1512760 title: Java applications leaks shmem chunks

See also: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=799587#20 which is the reference for Debian

If the error appeared out of nowwhere (missing info from u), this can come from a messy update.

You can justify this by looking into your APT-History: $var/log/apt/history.log

$java -version

tells what the installed version is. Awaiting reply from you...

  • what happens to me correspond to the issue reported in that bug report Nov 18, 2015 at 8:55
  • It wouldn't hurt to add OpenJDK-6-JRE and select this than via the alternatives system. Since u cannot install OpenJDK-8 to solve this & OpenJRE-6 doesn't seem to be affected. Saying so from looking at the changelogs just run dpkg-query -l openjdk-* | grep ^ii and for the browser-plugin dpkg-query -l icedtea* | grep ^ii Post the result here, as ur question has now sufficient content, to my mind. Nov 19, 2015 at 1:07
  • 1
    Hi, I attached the output of the commands in my question (I didn't have enought characters to insert it as comment) but it seems solved by installing openjdk-6. Nov 19, 2015 at 10:29
  • Once the fix arrives for OpenJDK-7 (which might take a while in (K)Ubuntu) u should just remove OpenJDK-6 and Icedtea-6. The alternatives-system will automatically shift. The next higher solution would have been to use the ppa-version for testing & feedback as suggested in comment# 14 in LP-bug-report #1512760 Remember that the solution we found is only a workaround Nov 19, 2015 at 14:25

If the issue remains, we should take a look into log-files in order to find errors via Terminal/Konsole (just C&P the commands):

egrep "EE|WW" /var/log/Xorg.0.log*

lspci -nnk | grep -iA2 vga

tail -n 50 ~/.xsession-errors

It's senseless to make guesses out of nowwhere. It could even be an effect of overheating or the signs of a dieing graphis-card. Check ventilators for dust! Or some PPA.

O.k. Since we know now it's hybrid graphics Laptop with a Intel HD4000 / Nvidia GT650M - we need more Information:

uname -a

dpkg-query -l xserver-xorg-core* | grep ^ii

dpkg-query -l *-lts-* | grep ^ii

qdbus org.kde.kwin /KWin supportInformation

  • Thanks, I edited my question with the output of the commands you suggested to run Nov 17, 2015 at 12:17
  • Editet my answer to come to a higher level of knowledge regards your laptop. Is this an update from a previous version or a new installation? Do you use Prime or Bumblebee to switch the graphics-card? Nov 17, 2015 at 19:48
  • It has only one GPU (HD3000). Nov 18, 2015 at 12:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.