1

My gateway laptop mouse pointer locks after a while of no use. I am referring to built in touch pad.

How can I shutdown without a mouse? How can I restart the mouse? How can I eliminate the problem?

Per a suggestion I ran

larry@larry-Satellite-C70-A:~$ xinput
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=11   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ TOSHIBA Web Camera - HD                   id=9    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=10   [slave  keyboard (3)]
    ↳ Toshiba input device                      id=12   [slave  keyboard (3)]
3
  • Is it a wireless mouse? Can you tell more about hardware?
    – dedunu
    Nov 13, 2015 at 2:54
  • Can you run xinput from the terminal and edit your question to include the output? (This doesn't mean that I know the answer - it is just something you should probably include so that others can better help you.)
    – KGIII
    Nov 13, 2015 at 3:02
  • Also, see this for maybe an answer and a work-around until you get an answer.
    – KGIII
    Nov 13, 2015 at 3:04

2 Answers 2

0

This worked for me with a similar problem (might not work if you don't have a Synaptic touchpad).

  • Open terminal (Press CtrlAltT)
  • Type synclient TouchpadOff=0 and press enter. This should reactivate the Touchpad.

If you just need to turn off your computer without a mouse, just open terminal (CtrlAltT) and type:

sudo poweroff

For a restart type:

sudo reboot
3
  • Thanks, doesn't work on my gateway which has the problem. Does turn the touchpad on and off on my Toshiba Satellite.
    – lle
    Nov 14, 2015 at 0:43
  • Alas.. It was worth a shot. And your question implied you also want to know how to shut down your computer w/o a mouse. So I added that to the answer.
    – Moose
    Nov 14, 2015 at 0:54
  • Yes I did, and now I know, thanks to your answer.
    – lle
    Nov 15, 2015 at 3:44
0

Since I submitted this question I have worked out a solution to it.

Recovering from a hung mouse pointer is "easy to do" if you have my script "mykitty" installed.

To install it just copy it from the public folder at
https://spideroak.com/browse/share/lle_public1/lle to your home folder.

Then open a terminal window by hitting the t key while holding down the control and alt keys. Hit the enter key.

At the prompt, enter ./mykitty -h then hit the enter key. The help text will be displayed.

When your mouse hangs run ./mykitty to get the mouse running again.

If that fails to free the mouse run ./mykitty -r to restart your system.

If you find this solution to is useful, please promote it. Otherwise you have been reminded that "easy to do is easy to say".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.