I've downloaded FileZilla on Ubuntu 14.04 (Trusty Tahr) using the package manager (apt-get) and I'm currently setting up a site to transfer files for on the remote server I'm using.

For the login type, I need to use a private key, but it's not listed as an option. Did I install the wrong version of FileZilla or something? I tried to upgrade the installation, but it says that FileZilla is up to date.

  • 1
    Do you really need Filezilla? The default file browser can do SFTP. Press Ctrl-L, the address bar should show up and then you can browse to sftp://some.server.
    – muru
    Nov 13, 2015 at 2:20

2 Answers 2


You have to configure the key authentication.

Open the menu Edit > Settings… and navigate to Connection > SFTP.

Add the key files and you're done.

enter image description here

  • 1
    I tried to add a ssh key file on this page by selecting it after having clicked the "Add Keyfile" button, but a dialog box popped up saying that file was apparently in the wrong format and needed to be converted to the putty format (.ppk or something). When I clicked yes, it brought up the file manager, but no longer shows the keyfile in the directory where its stored. What is the proper way to add the file or should I use the other option of using the system's SSH agent (I don't know how to do that either though) ? Nov 17, 2015 at 1:02
  • Sorry, be fair. That's a completely different question. You should ask a new one. Answering new questions in comments is confusing for other readers.
    – A.B.
    Nov 17, 2015 at 7:13
  • Right, here is the new post: askubuntu.com/questions/700164/… Nov 19, 2015 at 21:00
  • Thanks for the link. Seems, your question here was solved. You could accept the answer here. Click the check mark at the left side of the answer. And perhaps an upvote.
    – A.B.
    Nov 20, 2015 at 7:04
  • You have to login with the "normal" option and leave the password blank (you shoud have added the ssh key file in the options before, like explain in this answer)
    – Leto
    May 10, 2018 at 8:43

The fix for me was to switch the logon type to Key File. In my case, I have an Ubuntu user with the correct permissions which I used the link below to configure.

I had tried the answer above, but it did not work. I guess it may have if the user was in fact root?

Link to create a non root user to log in with SSH key: https://www.digitalocean.com/community/questions/secure-ubuntu-server-for-non-root-user-using-only-ssh-keys

In FileZilla: FileZilla example

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .