Hardware: Lenovo Carbon X1

OS: 14.04

$ lspci | grep VGA

00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)

Recently after an apt-get update I noticed sluggish graphic performance, and compiz is running at 120-220%. When I go to "About This Computer" the graphics is listed as "Gallium 0.4 on llvmpipe (LLVM 3.4, 256 bits)", which from what I've gleaned from Google means that the Intel drivers aren't loading properly. My xorg log doesn't have anything out of the ordinary. intel-linux-graphics-installer is already installed,and "additional drivers" has nothing listed. I even tried the intel graphics installer and it said 14.04 isn't supported. What can I do to get hardware acceleration back? I've killed a whole day at work trying all of the things I've found on google, and nothing is working.

2 Answers 2


Try loading the oibaf drivers from the launchpad website. They have good instructions for both loading and unloading the drivers, and they work really well with the integrated intel graphics in my laptop.

sudo add-apt-repository ppa:oibaf/graphics-drivers
sudo apt-get update
sudo apt-get upgrade
sudo reboot

will install the drivers

sudo apt-get install ppa-purge
sudo ppa-purge ppa:oibaf/graphics-drivers

will remove the drivers

  • I just tried that: Graphics still list Gallium 0.4 on llvmpipe (LLVM 3.4, 256 bits)
    – matt
    Nov 12, 2015 at 21:53
  • Do you still have the intel drivers loaded in the additional drivers? I think that you may need to remove them. Although congrats on getting it working in the first place! I gave up on them a couple of years back. Nov 12, 2015 at 21:58
  • It says no additional drivers available and "No proprietary drivers are in use". I'm not even sure I ever got them to work, everything just worked fine out of the box for about a year now. I only recently started having performance issues with compiz so I had to research what was causing it. I checked my apt-get logs and nothing relating to video or intel was replaced. I suppose I could try to update to a newer version of Ubuntu, but I really wanted to wait until the next LTS. Isn't that why we have LTS?
    – matt
    Nov 12, 2015 at 22:05

I figured it out. A few days earlier I had modifed my /etc/default/grub and set GRUB_CMDLINE_LINUX_DEFAULT='nomodeset' in an attempt to fix another problem I was having. setting that value back to "quiet splash" then running update-grub fixed the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.