0

I'm new to ubuntu and my Asus X555LA brought me here.

The fn + (brightness up/brightness down) is not working, i did some search and what i tried till now is modifying grub file from etc\default

GRUB_CMDLINE_LINUX="acpi_osi=Linux"
GRUB_CMDLINE_LINUX="acpi_backlight=vendor"
GRUB_CMDLINE_LINUX="acpi_osi=linux acpi_backlight=vendor"
GRUB_CMDLINE_LINUX="acpi_osi_Linux"

To mention fn+brightness works in BIOS and i use ubuntu 15.10 but the same problem is in 14.04 or 14.10.

Now is there any other solution? And if there is please can you explain it on baby steps :-?

hw:

-cpu

      product: Intel(R) Core(TM) i3-5010U CPU @ 2.10GHz
      vendor: Intel Corp.
      physical id: 1
      bus info: cpu@0
      size: 2100MHz
      capacity: 2100MHz
      width: 64 bits

-display

         description: VGA compatible controller
         product: Broadwell-U Integrated Graphics
         vendor: Intel Corporation
         physical id: 2
         bus info: pci@0000:00:02.0
         version: 09
         width: 64 bits
         clock: 33MHz
         capabilities: msi pm vga_controller bus_master cap_list rom
         configuration: driver=i915 latency=0
         resources: irq:48 memory:b1000000-b1ffffff memory:c0000000-cfffffff ioport:4000(size=64)

PS: I did found xbacklight app with custom keys, but the fact that fn on brightness doesn't work bugs me.

edit:

ls /sys/class/backlight

asus-nb-wmi intel_backlight

Thanks, Kim

  • Please edit your question and add output of ls /sys/class/backlight – Pilot6 Nov 14 '15 at 16:34
  • Did you try boot parameter acpi_osi=? Without any "Linux", etc. – Pilot6 Nov 30 '15 at 15:03
  • Yes did that, i found out that my fn and brightness keys are not bound to any event... i did some dig and there's a way to do it but it's to complicated, so first i need to get used with ubuntu then maybe ill try fix that :-? – Cravenica Dec 2 '15 at 12:05
0

If you can use xbacklight, then you need to point the default control to intel_backlight.

Run

sudo -H gedit /usr/share/X11/xorg.conf.d/20-intel.conf

and paste this text to gedit:

Section "Device"
    Identifier "Card0"
    Driver "intel"
    Option "Backlight" "intel_backlight"
    BusID "PCI:0:2:0"
EndSection 

then reboot.

  • Still not working, with this one i can't even modify the brightness from system settings or xbacklight. I did update grub every time... – Cravenica Nov 12 '15 at 22:05
  • I updated the answer. – Pilot6 Nov 14 '15 at 16:41
  • still nothing ... does my grub need to look like this or im doning something wrong ? GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=intel_backlight" GRUB_CMDLINE_LINUX="" – Cravenica Nov 14 '15 at 21:03
  • It is wrong to put this to linux cmdline. – Pilot6 Nov 14 '15 at 21:10
  • ok, i changed it back to quiet splash then reboot, and still nothing :-s the fn+brightness is not working. i'm still using normal key bind to use the xbacklight app – Cravenica Nov 14 '15 at 21:31
0

I have asus and i had same problem since 15.04 this how i fix it

install latest intel driver from http://01.org/linuxgraphics

then edit grub as below

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi= acpi acpi_backlight=vendor GRUB_CMDLINE_LINUX="noprompt persistent"

  • i tried it and still not working. the weird part is that there's no event on brightness key's and I think that's the main problem, but i don't know how to link those key to an event – Cravenica Jan 11 '16 at 11:24
  • I tested brightness Fn keys with command acpi_listen and there was no event, after did above steps it's working – user1998978 Jan 16 '16 at 5:48
0

FYI: After upgrading to 17.04 this issue no longer occurred.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.