0

Wireshark is not displaying my PPPoE connection in its interface list. Official wireshark website says PPP connections can be captured by configuring the ppp daemon and I've no idea how to do the same.

My Ubuntu version : 14.04.3

Wireshark version : 1.10.6 (from Ubuntu Software Center)

My Network Screenshot:

enter image description here

enter image description here

Wireshark empty interface list: enter image description here

I've even tried a solution from here but the problem still remains.

1

Quit Wireshark, run the command sudo dpkg-reconfigure wireshark-common, and then start up Wireshark again.

Wireshark lists no interfaces, which means the problem may have nothing to do with PPPoE, and may have to do with Wireshark (or, rather, the dumpcap program it runs to do capturing) not having enough privileges to capture traffic. Running Wireshark as root is An Extremely Bad Idea; the right way to give "minimum privileges" to Wireshark on Debian and on Debian derivatives such as Ubuntu is with the sudo dpkg-reconfigure wireshark-common command.

What you read on the official Wireshark website is talking about capturing PPP control traffic; you can capture data, such as IP traffic, on a PPP device, with tcpdump/Wireshark/etc.. I'm not sure the PPP daemon is even involved with PPPoE, so that may not apply.

  • Thanks, but after using your command I got some access denied error in wireshark saying "couldn't run /usr/bin/dumpcap" Hence I used the following commands from here which solved my problem. "sudo addgroup -system wireshark" "sudo chown root:wireshark /usr/bin/dumpcap" "sudo setcap cap_net_raw,cap_net_admin=eip /usr/bin/dumpcap" "sudo usermod -a -G wireshark YOUR_USER_NAME" – arpit Nov 13 '15 at 11:40
  • If sudo dpkg-reconfigure wireshark-common doesn't work, that sounds like a bug in the Ubuntu package; report it to the Ubuntu maintainers. – user126192 Nov 14 '15 at 0:41

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.