0

I've some issues with a windows share on Ubuntu 14.04 LTS.

  1. Installed cifsutils`:

    sudo apt-get install cifs-utils
    
  2. Created mountpoint

    sudo mkdir /mnt/temp
    
  3. Trying to mount a shared folder

    sudo mount -t cifs //fileserver/share /mnt/temp -o username=user,password=xxx
    

My problem is that the console hangs forever. I've waiting several minutes. If I enter wrong user/password it tells me Permission denied.

Update:

Response from Ubuntu Host computer:

nmap -p -v 445 fileserver -P0

host seems down / Filesharing seems to work though!

Ubuntu client computer (Inside vmware):

nmap -p -v 445 fileserver -P0

Host seems down / Filesharing doesn't work!

Maybe a lead: To autorize the fileshare I have to login on the domain.

Any suggestions?

  • Does dmesg | tail show anything interesting at that point? – Jos Nov 12 '15 at 14:05
  • CIFS VFS: cifs_mount failed w/return code = -112 – Fam Wired Nov 12 '15 at 14:50
  • I'm not sure about this, because I have to ctrl-break the action to be able to continue. – Fam Wired Nov 12 '15 at 14:51
  • Please edit your question, if you want to add information. Especially file or program output listings (with the help of the {} button in the editor toolbar) are much more readable there and overall it's best to have everything relevant in one place. Also, comments may be deleted for various reasons. – David Foerster Nov 13 '15 at 7:35
0

This is firewall issue for me . Install nmap on your ubuntu box with apt-get install nmap and run nmap -p 445 fileserver to see if the samba port is blocked by firewall or not.

Other way is to put -v sudo mount -v -t cifs //fileserver/share /mnt/temp -o username=user,password=xxx to see the verbose message from the mounting.

Hope it helps

  • Thanks. I got nmap response: Host seems down. I'm running this ubuntu inside another ubuntu host (vmware) – Fam Wired Nov 12 '15 at 14:37
  • I think you have right about the firewall. Do you know how to open the port? – Fam Wired Nov 12 '15 at 14:38
  • So, run nmap -p 445 fileserver -P0. 100% this is firewall issue! – Nikolay Nikolov Nov 12 '15 at 14:39
  • If the machine is windows , go to windows firewall settings. If it is ubuntu , maybe you should stop apparmor – Nikolay Nikolov Nov 12 '15 at 14:40
  • It works OK on the ubuntu host computer. It's the ubuntu inside the ubuntu that failes. – Fam Wired Nov 12 '15 at 14:53
0

Another possibility:

If you are using a standard VMWare Network-Configuration for that Virtual machine and following the documentation at http://pubs.vmware.com/workstation-10/index.jsp?topic=%2Fcom.vmware.ws.using.doc%2FGUID-4B9B4A82-D0F7-4939-BD7B-B6BF92FF7350.html

In a typical configuration, the New Virtual Machine wizard sets up NAT for the virtual machine. You must select the custom configuration option to configure bridged networking or host-only networking. The wizard connects the virtual machine to the appropriate virtual network.

Check out the VM's Network-Configuration and switch to bridged networking so that the VM has access to the same network-resources as your host machine.

Hope it helps.

NOTE: It was intended to be a comment, but I cannot do that yet :)

  • Thanks, the net on the virtual machine is bridge configured as you pointed out. It also got a ip-address in the same subnet as the fileserver. :) – Fam Wired Nov 16 '15 at 9:04
  • Your solution was going to be my next answer :-D Glad you sorted this out. – Eduardo López Nov 16 '15 at 9:39
0

Finally I got it to work.

I used the ip-address (192.168.1.11) instead of fileserver.

When ping:ing the fileserver name on the client I got ping response from another ip/computer (192.168.1.16) than I got from the host computer (192.168.1.11) !

Don't know why the dns name was linked to wrong ip on the client computer?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.