40

How can I select all the text in a Terminator terminal? Ctrl-Shift-A does not work.

2
  • try to use Screen
    – Maraboc
    Nov 12, 2015 at 13:25
  • 1
    So, it seems this feature is still missing. Has anyone requested for it to be added to the next version of Terminator?
    – yuranos
    Mar 17, 2017 at 8:35

7 Answers 7

36

I don't have the menu bar, nor the option to show it. So I have this workaround:

  1. Shift + Home
  2. Select the first line
  3. Shift + End
  4. Shift + click on the last character
3
  • 5
    This should be the accepted answer.
    – Osolong
    Oct 3, 2019 at 19:16
  • I would have never figured out the shift + click part. Thanks you! Mar 11 at 23:17
  • This works for the regular terminal as well as with Terminator !!
    – cdahms
    Jun 18 at 17:43
29

The quickest way to select all / select specific text in Gnome Terminator:

  1. Click at the start of the text you want to select
  2. Scroll the window to the end of the text you want select
  3. Shift + click the end of your selection
  4. All text between your first click and your last Shift + click is now selected
  5. Then you can Ctrl + Shift + C your selection out of there

It's not a keyboard shortcut, but it's a lot faster than click-and-drag to select text, that's for sure.

11

Your select all is disabled by default.

  1. Go to Menu->Preferences->Shortcuts
  2. From Edit selection choose "Select All"
  3. Then to assign press Ctrl+Shift+A
3
  • 2
    I am surprised built-in solution doesn't get more recognition. It works for me in Gnome Terminal 3.36.2 (in Ubuntu 20.04.02 LTS). Is this a recent addition to Gnome Terminal? May 12, 2021 at 19:35
  • To do this, with my default settings (U21.04, 3.38.1): 2. In Edit selection, doubleclick "Select All". Singleclick just hangs there
    – Joe Kul
    Jan 10 at 13:33
  • @Joe Kul Press the keys. Simulate. Process number #3 above. Jan 11 at 10:22
5

No Shortcut, use Mouse: click on Menu -> Select All

Only true for Program: Terminal

3
  • 3
    There is no Menu Bar in my Terminator window. In the Context/Right-Click Menu only Copy and Paste is available
    – bmm
    Nov 12, 2015 at 13:34
  • 1
    It seems it is not implemented: bugs.launchpad.net/terminator/+bug/1091960
    – koni_raid
    Nov 12, 2015 at 16:41
  • As bmm wrote, there is no menu bar in Terminator.
    – fadedbee
    Feb 22, 2019 at 8:38
5

I had the same goal and modified Thierry Ds copyall-Terminator-Plugin to be just a select-all.

Install and activation:

  • copy selectall.py into /usr/share/terminator/terminatorlib/plugins/
  • restart terminator to discover the new plugin
  • in terminator:
    • right-click->Preferences
    • switch to Plugins tab
    • select SelectAll
    • click Close

Now you can Select-All by: right-click->Select all

Perhaps I should add a shortcut as well.

5
  • Is there a way to attach a keyboard shortcut to plugin actions? Struggling to find documentation
    – jberryman
    Jun 23, 2019 at 3:04
  • From what I've seen at first sight, I don't think that is currently possible. Jun 23, 2019 at 6:41
  • 2
    @EnnoGröper You have mixed tabs and spaces in selectall.py. Specifically, before terminal.vte.select_all() line you have a tab instead of spaces. May 31, 2020 at 15:49
  • @previous_developer Thanks for the hint. Fixed it. Jun 2, 2020 at 5:58
  • Groping for a long time, finally this solved :good:
    – yurenchen
    Aug 15, 2020 at 18:14
3
  1. Right click at terminal
  2. In menu check: Show menubar
  3. In the menubar: Edit->Select All
  4. Right click at terminal: Copy
1
  • This process copies ONLY current "terminal" page.
    – user580382
    Jun 3, 2019 at 0:47
1

(This depends on terminal/distro - what worked for me with huge output):

start selecting with mouse and then press PgUp/PgDn

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.