3

I am running Ubuntu 15.10 and ubuntu-gnome-desktop. Since the upgrade from 15.04 I have noticed that when I double click a window, that window seems to take focus (e.g., the gnome top bar text and icon change to that of the application whose window was clicked), but for all intents and purposes it does not have focus - text is still typed in the previous application, etc.

The only way I have found to really make an application take focus, is to click the title bar of the application. I am assuming this is a configuration/settings issue, but I have not been able to fix it in the gnome-tweak-tool or in the settings menu.

Is this a bug, the new intended behavior in 15.10, or just a setting I need to adjust? Thank you!

3

I believe I have a similar issue with Unity on Ubuntu 15.10. I found that running the unity-tweak-tool and setting auto raise to on and focus mode to "mouse" gets me the behavior I want. I suspect you can skip the auto raise if you don't like it, but the focus set at "click" is what seems to be causing the issue for me and "mouse" works as I'd expect.

enter image description here

|improve this answer|||||
  • 1
    Your suggestion is what I switched to after I posted this question, but it still is not exactly what I want. I have always used click for the focus mode instead of mouse, because I want the windows to take focus only when I click on them, but the behaviour of this mode seems to have changed in the most recent version. – elethan Nov 14 '15 at 19:38
  • To open the 'Additional' menu:(1)start 'Unity Tweak Tool' (2)Click on 'General' (3)On the right click on 'Additional'. – Rudy Vissers Nov 1 '17 at 8:13
1

Issue happens if you set Window Action Key to None in the Windows section of the Tweak Tool application.

Basic solution

Set Window Action Key option to Super or Alt

Tweak Tool preview

|improve this answer|||||
  • I've added solution. – Rusty Bishop May 31 '16 at 18:58
0

I'm having a similar issue with ubuntuGnome 15.10, I've solved it with the next steps:

  1. Install dconf-editor, using:

    sudo apt-get install dconf-tools
    
  2. Then run it:

    dconf-editor
    
  3. Navigate to:

    org / gnome / desktop / wm / preferences
    
  4. Check the option:

    raise-on-click
    

That's it!

enter image description here

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.