0

I set a drive to mount on boot and set the permissions with bindfs, but I still have no access rights, root only.

After reading everything on the issue I could possibly find, I found that mounting the drive in fstab, and adding a line for bindfs (is installed) would be the best way to do what I am trying, and did it to no avail (all users are admin's). I chowned the whole drive and chmoded it to 775 recursively but still have only limited access (access denied). I tried the drive with "default" and after some more research added the "noatime,nodev,nosuid" options, but neither work either.

I am trying to make it so that every user or a group of users has full rwx permissions, and no one is an owner of any file (or at least not in practice). It is to be used as a share for media and other non critical data, and there are documents everyone can contribute to, but I can not even edit and save files with different names.

Here is a copy of the relevant portions of my fstab file. Can anyone tell me WTH is wrong?!?!! (Preferably in N00Bspeak)

UUID=88c8e156-8e5a-405d-aeec-72e7eb9e81a5  /media/ARCHIVEZ       ext4    noatime,nodev,nosuid          0       0
bindfs#/media/ARCHIVEZ /media/ARCHIVEZ fuse -p=0775,-m=1000:1001:1002:1003,group=1002 --multithreaded  0       0

Ubuntu Studio 15.10 Willy Ware wolf

  • You probably need to assign proper permissions to the share or use acl. askubuntu.com/questions/52584/shared-folders-for-all-users and askubuntu.com/questions/158694/… – Panther Nov 12 '15 at 1:13
  • your fstab entry looks off, no "-" , example perms=0700,mirror-only=user1:user2:user3 – Panther Nov 12 '15 at 1:16
  • Thanks bodhi.zazen, I will read up on acl. I used the short form according to bindfs man and help, so -m is the same as mirror-only, unless I read it wrong. – zoidmaster Nov 12 '15 at 1:24
  • The first link is difficult to understand, to much stuff a N00B can not understand, but the second one describes my problem to a tee. – zoidmaster Nov 12 '15 at 1:36
  • yes, but you have -m rather then m , same with p, and --muitithread. Those are command line options, not fstab options. – Panther Nov 12 '15 at 1:38
0

Well since nobody is willing or able to help, I have meanwhile worked out the issue using als, but just in case you have the same problem, here are a few notes:

No matter what you set in als, thunar file manager will not display the right permissions in its properties so ignore those or you will think you did something wrong. Give the terminal some time to load and process files on larger directories, it may do nothing for a while, and you may think it is done and close it (I don't know if that will stop any processing) but you should see it working through the files until it returns a prompt again. If you want to start with a clean slate, and completely wipe all ownership and permissions on the whole drive, partition or directory first, files and all recursively then start with:

{sudo chown -R nobody:nogroup /path/to/directory/or/mountpoint}

Do not leave it like that for long if you have safety concerns though. Unmount, remount, if its a drive. Pick an owner, make a new group and add those you want to give access to (don't use a users group), chown again to give that user and the group ownership. If you add users to that group some day down the road, they will have the same permissions assigned automatically. Use acl to set read, write and execute permissions.

In most modern Linux distributions, als is enabled by default on ext3 and ext4 partitions and needs not be added to fstab options. There are quite a few guides to using als so look them up, I found a GUI to make it easier called "eiciel" and when run with root permissions {gksu eiciel} it will let you set the permissions for the group with ease.

Since so many think that sharing a drive amongst friends and family reeks of communist hippie commune gone amok, and don't get why anyone would want to do it, I just may write an EASY TO FOLLOW and THOUROUGH guide on the matter, as it seems to be fashionable around here to assume that everyone is familiar and comfortable in a terminal interface from the stone age! FYI I am not a programmer, just a measly electrical engineer, and I had to go through a load of sites with, useless, partial and outdated and non descriptive information, to gather enough info to do it right without hosing the computer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.