1

From the root directory,

I uninstalled couchDB on a server with:

 sudo apt-get purge couchdb

Installing couchDB on a server with:

 sudo apt-get install couchdb -y

I get the error:

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies. couchdb : Depends: couchdb-bin (>= 1.6.1-0ubuntu5) but it is not going to be installed E: Unable to correct problems, you have held broken packages.

So, I tried:

sudo apt-get clean
sudo apt-get install -f
sudo dpkg --configure -a
sudo apt-get update

Then,

sudo apt-get remove couchdb couchdb-bin couchdb-common -f
sudo apt-get install python-software-properties
sudo apt-add-repository ppa:couchdb/stable
sudo apt-get update
sudo apt-get install couchdb couchdb-bin couchdb-common -f

I get the error:

The following packages have unmet dependencies. couchdb-bin : Depends: erlang-abi-15.b E: Unable to correct problems, you have held broken packages.

I tried,

 sudo apt-get remove erlang-abi-15.b

I get error:

Virtual packages like 'erlang-abi-15.b' can't be removed

So I do:

 sudo apt-get install erlang-abi-15.b

I get error:

Package erlang-abi-15.b is a virtual package provided by: erlang-base-hipe 1:17.3 [Not candidate version] erlang-base 1:17.4 [Not candidate version] erlang-base 1:17.1 [Not candidate version] erlang-base-hipe 1:17.3.2 [Not candidate version] erlang-base 1:17.3 [Not candidate version] erlang-base-hipe 1:17.1 [Not candidate version] erlang-base-hipe 1:17.4 [Not candidate version] erlang-base 1:17.3.2 [Not candidate version] erlang-base-hipe 1:16.b.3-dfsg-1ubuntu2.1 [Not candidate version] erlang-base 1:16.b.3-dfsg-1ubuntu2.1 [Not candidate version] erlang-base-hipe 1:16.b.3-dfsg-1ubuntu2 [Not candidate version] erlang-base 1:16.b.3-dfsg-1ubuntu2 [Not candidate version]

E: Package 'erlang-abi-15.b' has no installation candidate

So I try:

 sudo apt-get update && sudo apt-get install -f

And try installing couchDB again with

 sudo apt-get update
 sudo apt-get install software-properties-common -y
 sudo add-apt-repository ppa:couchdb/stable -y
 sudo apt-get update
 sudo apt-get remove couchdb couchdb-bin couchdb-common -yf
 sudo apt-get install couchdb -y

And I get the same error:

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies. couchdb : Depends: couchdb-bin (>= 1.6.1-0ubuntu5) but it is not going to be installed

I'm running erlang version 18 (the latest).

I don't know what else to do, help would be appreciated. I think I have been as thorough as possible with this.

1

Apparently the latest version of erlang-base (1:18.1) does not include the virtual package erlang-abi-15.b.

If you use aptitude to install couchdb, it's capable of offering a solution to this problem, namely downgrading erlang to 1:17.4. Although you have to reject its first suggestion (which is not to do anything).

Here's the output from my run of sudo aptitude install couchdb:

$ sudo aptitude install couchdb
The following NEW packages will be installed:
  couchdb couchdb-bin{ab} couchdb-common{a} erlang-eunit{a} erlang-os-mon{a} erlang-snmp{a} erlang-tools{a} erlang-webtool{a} erlang-xmerl{a} libmozjs185-1.0{a} 
0 packages upgraded, 10 newly installed, 0 to remove and 0 not upgraded.
Need to get 8,256 kB of archives. After unpacking 22.1 MB will be used.
The following packages have unmet dependencies:
 couchdb-bin : Depends: erlang-abi-15.b which is a virtual package.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     couchdb [Not Installed]                            
2)     couchdb-bin [Not Installed]                        



Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

      Install the following packages:                                 
1)      erlang-eunit [1:17.4 ()]                                
2)      erlang-os-mon [1:17.4 ()]                               
3)      erlang-snmp [1:17.4 ()]                                 
4)      erlang-tools [1:17.4 ()]                                
5)      erlang-webtool [1:17.4 ()]                              
6)      erlang-xmerl [1:17.4 ()]                                

      Downgrade the following packages:                               
7)      erlang-asn1 [1:18.1 (, now) -> 1:17.4 ()]         
8)      erlang-base [1:18.1 (, now) -> 1:17.4 ()]         
9)      erlang-crypto [1:18.1 (, now) -> 1:17.4 ()]       
10)     erlang-inets [1:18.1 (, now) -> 1:17.4 ()]        
11)     erlang-mnesia [1:18.1 (, now) -> 1:17.4 ()]       
12)     erlang-public-key [1:18.1 (, now) -> 1:17.4 ()]   
13)     erlang-runtime-tools [1:18.1 (, now) -> 1:17.4 ()]
14)     erlang-ssl [1:18.1 (, now) -> 1:17.4 ()]          
15)     erlang-syntax-tools [1:18.1 (, now) -> 1:17.4 ()] 

      Leave the following dependencies unresolved:                    
16)     erlang-base recommends erlang-crypto (= 1:17.4)               


Accept this solution? [Y/n/q/?] y
The following packages will be DOWNGRADED:
  erlang-asn1 erlang-base erlang-crypto erlang-inets erlang-mnesia erlang-public-key erlang-runtime-tools erlang-ssl erlang-syntax-tools 
The following NEW packages will be installed:
  couchdb couchdb-bin{a} couchdb-common{a} erlang-eunit{a} erlang-os-mon{a} erlang-snmp{a} erlang-tools{a} erlang-webtool{a} erlang-xmerl{a} libmozjs185-1.0{a} 
0 packages upgraded, 10 newly installed, 9 downgraded, 0 to remove and 0 not upgraded.
Need to get 19.1 MB of archives. After unpacking 21.5 MB will be used.
Do you want to continue? [Y/n/?] y

UPDATE: I have reported this bug to Ubuntu.

0

The conflict has to do with erlang-base and whether it's manually installed. If you remove all traces of couchdb and erlang, then install couchdb it should work.

Rough sequence of steps:

$ apt-get remove couchdb couchdb-bin erlang-base erlang-base-hipe erlang-solutions
$ apt-get install couchdb

After doing this, erlang-base will not be installed, and a bunch of other erlang packages will be installed at version 1:16.b.3.

$ dpkg --list | grep erlang
ii  erlang-asn1                                           1:16.b.3-dfsg-1ubuntu2.1                            amd64        Erlang/OTP modules for ASN.1 support
rc  erlang-base                                           1:18.1                                              amd64        Erlang/OTP virtual machine and base applications
ii  erlang-base-hipe                                      1:16.b.3-dfsg-1ubuntu2.1                            amd64        Erlang/OTP HiPE enabled virtual machine and base applications
ii  erlang-crypto                                         1:16.b.3-dfsg-1ubuntu2.1                            amd64        Erlang/OTP cryptographic modules
ii  erlang-eunit                                          1:16.b.3-dfsg-1ubuntu2.1                            amd64        Erlang/OTP module for unit testing
ii  erlang-inets                                          1:16.b.3-dfsg-1ubuntu2.1                            amd64        Erlang/OTP Internet clients and servers
ii  erlang-mnesia                                         1:16.b.3-dfsg-1ubuntu2.1                            amd64        Erlang/OTP distributed relational/object hybrid database
ii  erlang-os-mon                                         1:16.b.3-dfsg-1ubuntu2.1                            amd64        Erlang/OTP operating system monitor
ii  erlang-public-key                                     1:16.b.3-dfsg-1ubuntu2.1                            amd64        Erlang/OTP public key infrastructure
ii  erlang-runtime-tools                                  1:16.b.3-dfsg-1ubuntu2.1                            amd64        Erlang/OTP runtime tracing/debugging tools
ii  erlang-snmp                                           1:16.b.3-dfsg-1ubuntu2.1                            amd64        Erlang/OTP SNMP applications
rc  erlang-solutions                                      1.0                                                 all          A package to add repository.
ii  erlang-ssl                                            1:16.b.3-dfsg-1ubuntu2.1                            amd64        Erlang/OTP implementation of SSL
ii  erlang-syntax-tools                                   1:16.b.3-dfsg-1ubuntu2.1                            amd64        Erlang/OTP modules for handling abstract Erlang syntax trees
ii  erlang-tools                                          1:16.b.3-dfsg-1ubuntu2.1                            amd64        Erlang/OTP various tools
ii  erlang-webtool                                        1:16.b.3-dfsg-1ubuntu2.1                            amd64        Erlang/OTP helper for web-based tools
ii  erlang-xmerl                                          1:16.b.3-dfsg-1ubuntu2.1                            amd64        Erlang/OTP XML tools

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.