0

I was running out of space on my 172 Gb HDD, so I bought a 465 Gb replacement, and used the DD command in terminal to copy the old to the new. DD, of course, created a partition exactly 172 Gb in size, so I then booted off a Linux Mint Live CD and used Gparted to expand the 172 Gb partition to the entire disk, and it SEEMED to work fine... except that now, Ubuntu does not recognize that any changes have been made, and still thinks only 172 Gb is available. Gparted, however, DOES see the resized partition, so as far as it is concerned, nothing is wrong. This is a pure Ubuntu installation, no dual-boot. I have attached screenshots of Gparted and Disk Usage Analyser's mutually incompatible results. Has anyone seen this before? Any ideas?

![Gparted Results]/home/rex/Pictures/Screenshot from 2015-11-11 13:17:25Gparted Results.png ![Disk Analyser Results for boot]/home/rex/Pictures/Screenshot from 2015-11-11 13:18:09Disk Analyser Results for boot.png

![Disk Analyser Results for whole disk]/home/rex/Pictures/Screenshot from 2015-11-11 13:18:46Disk Usage Analyser Results for Whole Disk.png

output of sudo parted -l

Model: ATA WDC WD5000AAKX-0 (scsi) 
Disk /dev/sda: 500GB 
Sector size (logical/physical): 512B/512B 
Partition Table: msdos 

Number Start End Size Type File system Flags 
1 1049kB 256MB 255MB primary ext2 
2 257MB 500GB 500GB extended 
5 257MB 500GB 500GB logical lvm 

Model: Generic Flash Disk (scsi) 
Disk /dev/sdb: 15.9GB 
Sector size (logical/physical): 512B/512B 
Partition Table: msdos 
Number Start End Size Type File system Flags 
1 1184kB 15.9GB 15.9GB primary fat32
12
  • Your pictures did not post into your question correctly. Can you upload the images to imgur, and add the links to the images to your question? Nov 11, 2015 at 21:41
  • I would be absolutely delighted to... if I had the vaguest idea how! (LOL).
    – Rex Brocki
    Nov 11, 2015 at 22:00
  • ...and I notice that somehow, my apology in advance for my hopeless ignorance at any social media, including these forums, got snipped off my original question... sorry.
    – Rex Brocki
    Nov 11, 2015 at 22:02
  • I;ve never used it myself (blush). Let's go old school. please execute the command sudo parted -l and paste the output into your question Nov 11, 2015 at 22:03
  • I would be absolutely delighted to add my images... if I had the vaguest idea how! (LOL). In addition, somehow my apology in advance did not make it through the posting process. The missing text read: "...and an apology: I am COMPLETELY ignorant of the niceties of social media, these forums included, so if I have asked the wrong type of question, wrong place, etc., please just tell me. I'm not malicious, just ignorant."
    – Rex Brocki
    Nov 11, 2015 at 22:05

1 Answer 1

0

For the record, I finally solved it: Logical Volume Manager (LVM) was having an argument with Gparted (Gparted thought there was now only one large partition after expanding /root to fill the whole drive, LVM didn't recognize the change Gparted had made). I went into LVM, and, closing my eyes tight and believing hard in fairies, told LVM to "Edit the Properties" of the "unused space" to match what Gparted had done, and it worked! I now have access to the whole drive. I hope this helps somebody else in the same mess.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.