Trying to install nodejs debian package that I built myself, i get error about missing: libc6-amd64 however, I am sure this lib is installed.

root@x72j:/home/reda/repo/git/node-debian# dpkg -i nodejs_5.0.0-1_amd64.deb 
Selecting previously unselected package nodejs.
(Reading database ... 151678 files and directories currently installed.)
Preparing to unpack nodejs_5.0.0-1_amd64.deb ...
Unpacking nodejs (5.0.0-1) ...
dpkg: dependency problems prevent configuration of nodejs:
 nodejs depends on libc6-amd64 (>= 2.14).

dpkg: error processing package nodejs (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db ( ...
Errors were encountered while processing:

and now the libc6-amd64:

root@x72j:/home/reda/repo/git/node-debian/nodejs-5.0.0/debian# apt-cache policy libc6-amd64
  Installed: 2.19-18+deb8u1
  Candidate: 2.19-18+deb8u1
  Version table:
 *** 2.19-18+deb8u1 0
        500 http://debian.ens-cachan.fr/ftp/debian/ jessie/main i386 Packages
        100 /var/lib/dpkg/status

What' could be the problem?

  • why down vote, please explain?
    – redochka
    Nov 19, 2015 at 9:48

2 Answers 2


I found the solutions

I had to remove all i386 package i have installed, build again my .deb and install it.

root@x72j:/home/reda/repo/git/node-debian# dpkg -l | grep i386
ii  gcc-4.9-base:i386                     4.9.2-10                             i386         GCC, the GNU Compiler Collection (base package)
ii  libc6:i386                            2.19-18+deb8u1                       i386         GNU C Library: Shared libraries
ii  libc6-amd64                           2.19-18+deb8u1                       i386         GNU C Library: 64bit Shared libraries for AMD64
ii  libc6-i386                            2.19-18+deb8u1                       amd64        GNU C Library: 32-bit shared libraries for AMD64
ii  libc6-i686:i386                       2.19-18+deb8u1                       i386         GNU C Library: Shared libraries [i686 optimized]
ii  libgcc1:i386                          1:4.9.2-10                           i386         GCC support library

apt-get remove --purge gcc-4.9-base:i386
apt-get remove --purge libc6-i386
  • 1
    How did you determine that the i386 packages were the cause? Jun 8, 2018 at 15:08

I faced the same problem due to a broken upgrade of PopOS. I tried the solutions above but did not work. I solved it using some of the suggestions in this page

First sudo -i and then reinstall libc6:amd64 by doing:

dpkg -i /var/cache/apt/archives/libc6_x.xx-0ubuntux_amd64.deb 

replace x with the correct version.

Then I was able to run apt --fix-broken install && apt update && apt upgrade

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.