9

After the screen saver activates, or after I manually lock the screen via Ctrl+Alt+L, I see a blank black screen with just the date / time in the upper right corner. A few seconds after that, my HP flat screen monitor(s) lose the video signal and display ugly hopping "No Input Signal" boxes.

I'd like to keep the blank black screen (It's less distracting, consumes about as much power, and allows me to unlock faster, as the monitors don't have to re-sync), so Ubuntu should keep driving the video output while the screen is locked.

How can I configure this? I'm using Ubuntu 14.04.3 LTS with the Gnome Classic Fall-back. Graphics card is NVIDIA with the open source Nouveau driver, but I also see this with an external HP NL571AA USB graphics adapter.

  • This has nothing to do with Ubuntu. It is probably part of the monitor's feature. – Sachin Kamath Nov 16 '15 at 12:36
  • 3
    The operating system turns off the video signal; any monitor is then forced to react. Yes, this problem isn't limited to Ubuntu (but that's what I'm using), but I mostly see issues with other shared components (like Gnome, Firefox, etc.) discussed here as well, so I think it is on-topic. – Ingo Karkat Nov 16 '15 at 14:26
19
+50
  • This worked for me:

    xset -dpms
    

    The -dpms option disables DPMS (Energy Star) features.

  • For permanent solution:

    echo "xset -dpms" >> ~/.xinitrc
    

    If it doesn't work or want more user friendly way, add xset -dpms to:

    System Tools → Preferences → Startup Applications

    (Thanks goes to Ingo Karkat)

Reference: man xset

| improve this answer | |
  • 1
    Works for me, too. Thanks a lot; you've really earned the bounty with your persistence! – Ingo Karkat Nov 20 '15 at 15:41
  • 1
    Note that the ~/.xinitrc didn't work for me (using GNOME Classic); I instead put the xset -dpms into System Tools > Preferences > Startup Applications. – Ingo Karkat Nov 20 '15 at 16:13
  • 1
    This worked for me as well on Ubuntu 16.04 with gdm3. Thank you!! – dgreene Apr 3 '17 at 3:00
  • worked for me on ubuntu 18.04.3 – Elliot Gorokhovsky Apr 8 at 19:52
  • worked for me on Ubuntu 19.10. – Janos Apr 18 at 10:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.