14

I am using 11.10 with Gnome 3.2 and completely loving it. On one computer it works like a charm, but on another computer the super does not show the activities window. Mousing over the top-left corner does bring up the window, so I am not totally blocked, but I am really missing being able to just press the key to get there.

Does anybody have a clue how I could fix this?

[update] In System Settings, Keyboard, there is an option to change the shortcut for Show the activities overview, but I can't set it to super (I guess because it is considered to be a modifier-key). Any idea how I can solve that?

Screenshot

  • 1
    I'm experiencing this issue in Ubuntu 20.04. – Flimm Apr 24 at 12:40
  • 1
    Same - experiencing this with 20.04 – Viv Diwakar Apr 27 at 20:19
  • 3
    Same here on Ubuntu 20.04 it is pretty annoying. It works with En keyboard layout but it does not work with Pt-Br layout. – leoheck Apr 27 at 22:45
  • @leoheck - I confirm, this was a great input! I often switch between Swiss-German and en layout, and hadn't realized that the super key never works in German, while it does in en! – Lionel Trebuchon May 1 at 16:39
11

Okay. You might have locked your super button.

Try unlock it on your keyboard. It usually has two icons - a window key and a lock.

In my case, I have unlocked the super button by pressing

Right Fn + F12

Then everything is working perfectly.

| improve this answer | |
  • For me it was Fn + F2. Thank you so much! – Liam Baker Feb 20 at 15:19
  • On my keyboard it was Fn + F6. The F6 key is labeled "G/PC", which wasn't very descriptive. – Mathias Ose Sep 15 at 10:23
  • TY fn + f2 or me also. Why is that even an option lol – Michael Mantion Oct 19 at 23:54
  • mine was function f2 on illegear raven – James Tan Nov 15 at 4:19
11

finally found it myself.

In older Ubuntu versions, go to System Settings > Keyboard Layout > Layouts and then choose Options.

In newer Ubuntu versions, install Tweaks (sudo apt install gnome-tweaks) and open it, then Keyboard & Mouse and then choose Additional Layout Options.

There is an option for the Alt/Win key behaviour and there I had the option selected Meta is mapped to Win keys.

Deselecting that option, and choosing Alt and meta are on Alt keys fixes it for me. At least the super is working again to access the Activities. Not quite sure what the impact is of this choice.

enter image description here

| improve this answer | |
  • Hm that did the trick for me too! However, I don't understand the description of the option. One might think that ticking the option will make the Win key work as an Alt key. – Severo Raz Oct 29 '11 at 20:06
  • 1
    I had a similar problem with Debian 9.2, and this helped. In gnome-tweak-tool, under Typing > Alt/Win key behaviour I just chose some random option and afterwards set it to Disabled again (which was the default). It then worked again. – CharlyDelta Nov 23 '17 at 18:30
  • It did not work for me. – Flimm Apr 24 at 12:37
  • @Flimm not really sure why you edited my answer like you did? Would such a change not warrant a new answer? My answer is now outdated obviously --2011 and I have moved to mac osx sinc 2012 – nathanvda Apr 27 at 21:04
  • 1
    @nathanvda I made the answer up-to-date. The dialog is the same, you just need to go through a different set of menus to find it. If you think the answer is so out-of-date that it can't be edited to be made useful, feel free to delete your answer. (Stack Exchange doesn't have good solutions for information that gets out-of-date.) – Flimm Apr 28 at 12:18
2

Under gnome 3.4.2.1, I had to use "Meta is mapped to Win keys". Now shortcuts with Super key work now.

| improve this answer | |
  • It did not work for me. – Flimm Apr 24 at 12:37
0

In my case, I figured it was because "Overview Shortcut" was mapped to "Left Super", but I was clicking on "Right Super". Install tweaks and go to "Keyboard & Mouse" tab as follows: enter image description here

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.