1

Running Ubuntu 14.04LTS.

Enabled hibernation and manually tested pm-hibernate successfully. I updated the values in the gnome power manager i.e.

  • org.gnome.settings-daemon.plugins.power use-time-for-policy false
  • org.gnome.settings-daemon.plugins.power percentage-critical 5
  • org.gnome.settings-daemon.plugins.power percentage-action 4
  • org.gnome.settings-daemon.plugins.power critical-battery-action 'hibernate'

I get the warning at 5%, but when I hit 4% I get another warning that the computer will shutdown after which it gracefully shuts down instead of hibernating! I tried with the values 6%/5% as well, but no luck. I even tried to hibernate when I got that shutdown warning and it worked... but when I resumed with A/C, it gracefully shutdown right away since that command must have been queued just before I hibernated.

So I spent the last hour looking for a solution, but no one seems to have the exact same problem. People seem to complain about a sudden shutdown (as if there was no power left at all), not a graceful one. I haven't tried the solution suggesting the use of laptop-mode-tools, since I want to install more stuff on my laptop than necessary (and some people complained of sluggish behaviour following that route).

Any suggestion on how to troubleshoot this further?

  • The values are too low. Change the value for action to atleast 10%. – Raphael Nov 10 '15 at 20:48
  • Hibernate only takes a few second, so I don't understand why I would need to start taking a critical action when I have 20+ minutes of battery... but I'm willing to give it a try! I'll report back once I hit 10%... – tapz Nov 10 '15 at 21:04
  • I too don't understand but I have already tried what you are trying now, and the least possible value I found out was to be 10%. But if you use heavy programs such as avconv, then your laptop will hard shutdown even at 10%. – Raphael Nov 10 '15 at 21:09
  • No luck :( I set it to warning at 11% and action at 10%. I still get the graceful shutdown. Any logs I can look at to try to understand what's happening? – tapz Nov 10 '15 at 21:30
  • Did you add the shutdown action as .pkla? – Raphael Nov 10 '15 at 21:31
2

Enabling the hibernate seems to solve the issue. The solution can be found here at ubuntuhandbook.

  • :) Welcome. Glad! it helped. – Raphael Nov 11 '15 at 5:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.