39

I am trying to install Ubuntu 14.04 / 15.10 on my Dell XPS 13 9350 (November 2015).

I created a bootable USB disk which boots fine but the installer and the file manager do not detect the hard drive (128GB SSD).

What is the problem? How can I solve it?

67
  1. In Windows, run Command Prompt as admin
  2. Invoke a Safe Mode boot with the command: bcdedit /set {current} safeboot minimal
  3. Restart the PC and enter your BIOS during bootup.
  4. Change from IDE to AHCI mode then Save & Exit.
  5. Windows 10 will launch in Safe Mode.
  6. Right click the Window icon and select to run the Command Prompt in Admin mode from among the various options.
  7. Cancel Safe Mode booting with the command: bcdedit /deletevalue {current} safeboot
  8. Restart your PC once more and this time it will boot up normally but with AHCI mode activated.

(Source)

  • 1
    This saved my day. However I stuck on i/o err. – Amit Kumar Gupta Jun 3 '17 at 13:56
  • 3
    This is a good solution but only if you have Windows 10 installed already unfortunately... – hg8 Mar 27 '18 at 7:29
  • The Live USB was able to detect my hard drive and do the install after only running steps 1-4... – Michael Mandel Jun 5 '18 at 16:03
  • I'm stuck at step 5) since now instead of the PIN, it does not recognize my password. Any idea how I can stop it from booting in safe mode? – Adrian Jul 21 '18 at 11:44
  • 1
    In my case there was AHCI and RAID ON options in BIOS and it also worked. – renadeen Jul 29 '18 at 10:38
38

So far the only workaround I found is to switch to AHCI Sata mode in BIOS settings:

  1. Boot into BIOS (F12 at startup)
  2. Select Bios Setup.
  3. Move to System Configuration > SATA Operation and select AHCI.

Restart the computer and now the Ubuntu installer will detect the SSD.

Unfortunately this is not practical for a dual boot setup as Windows won't be able to boot in SATA mode so you every time will have to revert the BIOS settings when wanting to boot Windows.

  • @cl-netbox Indeed, unfortunately the pre-installed Windows is not in AHCI mode... – hg8 Nov 11 '15 at 10:14
  • 4
    You can create the boot recovery USB thumb drive, boot from there and repair windows install by choosing to "keep your personal files". Then windows will boot again in AHCI mode. – Metiu Nov 25 '15 at 12:39
  • I did switch it, but ubuntu 16.xx still does not see the ssd. – user1539216 Nov 4 '16 at 16:33
  • 4
    It also works in the new dell xps 15 – nanounanue Dec 8 '16 at 17:43
  • It was already in AHCI mode, but for some reason this did end up working – Taylor Mar 8 at 14:37
7

The main problem is that DELL shipped with Windows pre-installed in IDE mode. The best solution in every aspect is to perform a clean installation of Windows. As a side effect you achieve one big advantage: pure Windows without any crap.

  1. Create a Windows system backup before. Things may break badly!
  2. Boot from a GParted Live media and format the Windows partition with ntfs.
  3. Boot into BIOS/UEFI of the PC and change the settings to AHCI/SATA mode.
  4. Reinstall Windows.
  5. Disable Hibernation and Fast startup in Windows
  6. Boot from Ubuntu installation media and reinstall GRUB.
  7. Boot into BIOS and select Ubuntu to be the default operating system to boot. Now you can select which system to boot, without having to change settings.

For those users who don't want to reinstall Windows, there is a way to switch to AHCI mode:

  • so Windows install first, followed by Ubuntu install ? – toine Apr 26 '16 at 21:40
  • 1
    @toine : Yes, it is recommended to first install Windows and afterwards Ubuntu. :) – cl-netbox Apr 27 '16 at 16:59
0

I had the same issue on an old HP Compaq & it was due to RAID format. I remove this in the BIOS menu:

  • press ctrl + F12 on te startup & then quckly Ctrl + I one the Intel BIOS screen
  • Go in "Remove RAID" section & select your Hard Drive
  • exit from BIOS & then reboot
  • Hard drive should be visible from your Ubuntu installer

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.