I am running Ubuntu GNOME 15.10 with GNOME 3.18, and recently (after changing my password) the caps lock has suddenly not been working, now, I haven't yet noticed whether or not it is for everything or just my passwords, but I should imagine that it is for everything and I have only noticed for my password because I need to type it in and it has upper and lower case letters in it.

And as I only noticed it for my passwords and it happened after changing my password, I originally assumed that it was an issue with the authentication system that verifies whether or not my password is correct. Though now I have noticed that it is because of my system refusing me to type upper case letters at random times and forcing me to do a restart of my system if I want them (I am mostly getting locked out of my system when it suspends, though there was one occasion when it locked me out and upon logging into TTY1 it then allowed me to type upper case letters everywhere else - and that's another thing to note, it only affects one user session, so if I got to any other TTY it will work fine).

The other day it happened around 6:30 PM (I don't know about AM), and today also around the same time, though it also happened after that so I don't know if that is of relevance. And I think that maybe because that's the only time I really suspend my machine that is why I am noticing it then.

So this is getting rather annoying, how can I fix this? Is this some sort of bug? And if so, in what? I can see the little light go on on my keyboard which indicates that I am now using upper case, though this doesn't seem to make any difference.

Information Update:

It was requested that I provide the following information:

I have tried running crontab -l; sudo crontab -l and the output was:

no crontab for marvin
no crontab for root

My keyboard layout also stayed the same throughout all of the problems (en (UK)).

I have also come up with a bit of a workaround, and it also now seems only to be happening on the locked screen login, but after I have logged in the issue goes away. The workaround is that I can use the SHIFT key to use the upper case. But I would like a more permanent solution.

It also seems to be happening on the locked screen every time now, and is not time specific (not that I am sure that it ever was).

And now I have also noticed that it is not just on the locked screen, but also in the graphical password prompt (gksudo), and actually anywhere else in the system where I type anything (so not just my password), but not in applications, just places like in the Activities Overview search.

I haven't tried using a different keyboard, but I don't think that it is a hardware issue with my keyboard because after I did a fresh install a few days ago it's been working as it should until just now, when it has decided to start giving me the issue again.

  • Did you change your password in a terminal using the passwd command or via the graphical tool? Oh, and do you have a character in your new password that would change position for different keyboard layouts? – flaschbier Nov 10 '15 at 18:57
  • 1
    Have you verified that you don't have a keyboard that is going bad? I once spent a very frustrating several hours trying to debug a password issue, only to realize that one of my keys was only registering presses about half the time. – Don Simon Nov 10 '15 at 19:14
  • @flaschbier: GUI, and no. – user364819 Nov 10 '15 at 19:53
  • @DonSimon: Yes, my keyboard seems fine. – user364819 Nov 10 '15 at 19:54
  • @ParanoidPanda I am reading from your question that after reboot the passwd is accepted for a while until your issue arises. Pls change password via passwd from a terminal window and report whether the problem still occurs. – flaschbier Nov 11 '15 at 14:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy