7

My laptop doesn't entirely shut down. Everything goes black but the screen is still on and I have to force shutdown.

I don't know to which package should I post this bug to. How can I determine this ?

My laptop is an Acer TimeLine X 5820T, 8GB RAM, 240 Kingston SSD, Intel Graphics version and Ubuntu Gnome 15.10 64 bit.

  • What does this command do - $gnome-session-quit --power-off --force ? – Raphael Nov 10 '15 at 13:07
  • Same result still :( – userDepth Nov 10 '15 at 15:08
  • And this command: sudo shutdown -h now – Raphael Nov 10 '15 at 15:10
  • The same behaviour – userDepth Nov 10 '15 at 15:14
  • 1
    Could you add the model and specs of your machine and the Ubuntu version to your question? Also, are there any error outputs or other noticeable things (fans spinning, etc.) upon shutdown? – Prototype700 Nov 13 '15 at 0:56
6

Add a specification to your grub commandline option in the /etc/default/grub config file. This is the option that begins with GRUB_CMDLINE_LINUX_DEFAULT.

Try adding the following reboot=pci to that line. The changes would be:

Change from:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Change to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash reboot=pci"

After making changes to your grub configuration you will have to run the update command to activate the change:

$ sudo update-grub

(The $ sign is important in the line above. It's indicating a terminal commandline from the user's prompt.)

There are other reboot flags you can test if that one fails. The options includes:

  • warm - don’t set the cold reboot flag
  • cold - set the cold reboot flag
  • bios - reboot by jumping through the BIOS (only for X86_32)
  • smp (reboot by executing reset on BSP or other CPU - only for X86_32)
  • triple - force a triple fault - init
  • kbd - use the keyboard controller. cold reset (default)
  • acpi - use the RESET_REG in the FADT
  • efi - use efi reset_system runtime service
  • pci - use the so-called “PCI reset register”, CF9
  • force - avoid anything that could hang

Also, you can try multiple parameters at the same time such as:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash reboot=warm,cold,bios,smp,triple,kbd,acpi,efi,pci,force"

Other details can be found at:

http://michalorman.com/2013/10/fix-ubuntu-freeze-during-restart

  • I guess setting both the warm and cold reboot options in your last example line makes no sense... – Byte Commander Nov 16 '15 at 10:25
  • I had the same problem with a BRIX Mini computer. I experimented with lots of combinations until one worked. The idea of the example is to present how to include combinations. – L. D. James Nov 16 '15 at 10:57
2

It can be caused by some program which refuses to close while shutting down or after installing updates (happened with me). It can also be after changing your login screen (happened with me after installing lxdm). Before shutting down try to manually force close user apps using task manager. Also try updating your grub using

sudo update-grub

Usually it happens only after installing updates and should be resolved at next boot.

  • Yes I have had that experience before too but since I upgraded to an SSD this doesn't take more than 10 min tops. What is happening now is that the screen is left on when the system seems to be not working at all including ALT + F1 which has being usable in this case that you mention. – userDepth Nov 13 '15 at 17:27
  • auto update-grub worked for me on 17.04 – X09 Sep 14 '17 at 17:41
0

I have the same problem on every Linux OS! Actually there is nothing wrong with your OS, it's a bug in your kernel. The latest kernel now doesn't let the laptop shutdown, so it's better not to upgrade your kernel. I have already reported this bug.

So to fix the problem those who already upgraded to the newest kernel version have:

  1. Downgrade your kernel version.
  2. Upgrade the kernel again when the bug has been fixed.

In my opinion it's better for stability to run a Linux system that is 2 or 3 kernel versions behind.

  • 1
    Please add a link to your bug report. I decided to do a clean install and have upgraded to the latest Kernel. Maybe it was already fixed. Now I shut down and Reboot normally. – userDepth Nov 15 '15 at 16:31
  • I disagree with the advice to run old kernels. You should just not enable the proposed updates repository, but all those kernel updates from the other ones are usually stable and should not cause serious problems. And if you ever encounter one, you can just switch back to the last version that worked, but still upgrade when the next version comes out to test if the problem has been fixed. – Byte Commander Nov 16 '15 at 10:20
  • @ByteCommander I made a mistake and rolled back the wrong answer. I was fixing my answer when I was performing editing. I have searched for undoing what I accidentally did with this answer. Thanks in advance if you would help in getting it back into the proper and readable format in which you had. I'm still trying to figure out how to undo my mistake. I'll ask this question in the meta forum. – L. D. James Nov 16 '15 at 11:20
  • @L.D.James Done. You just do another rollback to the revision before the accidental rollback. :) – Byte Commander Nov 16 '15 at 11:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.