So, I've spent 2 days now, trying out different ways to install a dual boot and boot into GRUB. I've seen like 5 - 10 pages on how to install Ubuntu when Windows 8 and up is the original one. The latest one I followed is This guide on instructables, which I found the easiest to follow.

I have an Acer Aspire V3-772G which had Windows 8 when I bought it, now I have Windows 10 from the free upgrade. I love the way Linux work, so I want to install Ubuntu, because the one I feel I know best and I know it would fit me, because I'm a coder which love low level stuff.

I've successfully installed Ubuntu 14.04.3, But when I boot the computer I can't manage to get into GRUB, I just get into my Windows 10. I have UEFI, and I can't disable Secure Boot.

I've tried moving Windows Boot Manager to the bottom, I thought it would help but it didn't. I've also disabled Fast Boot, still not working. The only way I can get into Ubuntu is by Pressing F12 multiple times when booting, to get into the BIOS boot selection menu, choose the Ubuntu drive and get into grub that way.

What I want though is a way to boot directly into grub, and choose windows or ubuntu that way. I've also tried this command:

bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi

which I saw on this thread. Still didn't work. I did make sure to install a 64-bit Ubuntu because I do have a 64-bit laptop. And I also followed the (I may have said the name wrong) "how to get a UEFI bootable USB" (I use an USB because I have no CD/DVD available). So, I don't wanna give up, I would be very happy if I could get this working.


5 Answers 5


First, you probably can disable Secure Boot; you just haven't figured out how. For systems that shipped with Windows 8, Microsoft required that users be able to disable Secure Boot, so if it really can't be done, Acer is in violation of their contract with Microsoft. That said, the option could be completely hidden or named in a confusing way. That said, disabling Secure Boot should not be necessary -- it does work for you, or you wouldn't have been able to boot the installer. There is one exception, though....

In the bcdedit command you said you used, specifying grubx64.efi bypasses Shim, which is what Ubuntu uses to deal with Secure Boot. Thus, that particular command will work only if Secure Boot is disabled. The equivalent that should work with Secure Boot active is:

bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi

You can also try using EasyUEFI in Windows. This is a third-party GUI tool for managing EFI boot manager entries. Try moving the working ubuntu entry to the top of the priority list.

If that doesn't work, then chances are your firmware is defective. I'd say to return the computer to the store for a refund, but if you've had it for beyond the return period, you may be out of luck on that score. There is an ugly hack of a workaround, as described here (among other places). At a minimum, if you need to resort to this "solution," you should write to the manufacturer. If possible, return the computer for a refund because it's defective.

  • I have no idea why I didn't try this first, I tried now, and yeah, it worked. Thanks alot. Nov 10, 2015 at 14:27

I've had fought with this issue a couple of times, in my case, I can disable secureboot from BIOS, it can be frustrated but when you understand how it works it will be a piece of cake.

How you can try to make it work, use a live cd/usb to enter ubuntu interface and there you can choose two ways to repair the boot loader:

  • I've used to use Boot Repair easy: install click on "repair" button and follow the steps.
  • The other way to do it, and as my view, better: terminal way

Hope it helps :)


To achieve what you want first disable hibernation and Fast Boot in Windows.
To disable hibernation open command prompt as administrator and execute :

powercfg /h off  

To disable Fast Boot open Control Panel (the old version - not the modern design),
select the Energy Settings, enable show hidden settings and uncheck Fast Boot.

After completion - shutdown the machine completely - do NOT reboot !
Now select Ubuntu in BIOS / UEFI settings to be the default OS to boot.

Start the computer - when GRUB appears you're done - if not - next step :

Reinstall the GRUB boot loader to your Ubuntu installation in EFI mode.
Boot from the Ubuntu installation media - open a terminal and execute:

    sudo mount /dev/sd*** /mnt
    sudo mount /dev/sd** /mnt/boot/efi
    for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
    sudo chroot /mnt
    grub-install /dev/sd*


sd* = disk | sd** = efi partition | sd*** = system partition

To identify the partition numbers use GParted - it is included in the Ubuntu installation media.
Boot into BIOS and select Ubuntu in UEFI settings to be the default operating system to boot.


Since you haven't got the secure boot option, maybe you can enable legacy support in the BIOS? That setting prevented my computer from booting into grub.

Good luck!


This worked for me.

Search for Command Prompt, right click on it to run it as administrator. Then run:

bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi

If the "booting failed" error comes up, just disable Safe Booting from the BIOS menu.

Back as normal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.