12

I am using Ubuntu 11.10 and my screensaver keeps coming on while I'm watching a movie. I don't remember this happening in 11.04 and can't remember how to stop it?

11
  1. Open VLC Media player and go to Tools -> Preferences (Shortcut key is CtrlP)
  2. Select All from Show settings in the bottom-left corner of the Preferences window .
  3. Now click the Video Tab on the side.
  4. Now tick the Disable Screensaver box and click save.

enter image description here

  • 12
    That doesn't work. The 'Disable Screensaver' box is already checked. – Dave Oct 20 '11 at 20:15
  • Fixed in 2.2.0-rc1, VLC now uses dbus to communicate screensaving. – iElectric Nov 11 '14 at 6:49
  • 2
    still does not work in vlc 2.2.6 + LXDE – Patrick Apr 8 '18 at 13:49
5

Another solution but not what you want is:

Open the terminal and type:

xset s off

This will disable the screensaver.

to enable it again

xset s on


There are other options such as disabling for a period of time etc..

Type man xset in the terminal for more info

3

I've seen this happening with VLC as well as Banshee. The only solution I could find is to run Caffeine.

sudo add-apt-repository ppa:caffeine-developers/ppa
sudo apt-get update
sudo apt-get install caffeine

After that, run caffeine, go to its preferences and have it start on login. It sits in your system tray. Whenever you then watch a movie, you'll need to click on its system tray icon and select 'disable screensaver'.

It is not the best solution but it is the only one I can see in these early days.

  • 1
    This worked for now. You can configure Caffeine to automatically start preventing the screensaver and powersaving whenever a particular program is running. To set this up, just run the program that should inhibit the screensaver, right-click on the Caffeine applet, select “Preferences”, and then click “Add”. You should see a list of all running processes in the pop-up window. Click the name of the program that you started earlier and click “Add”. Close the preferences window. – Dave Oct 20 '11 at 20:23
  • This doesn't seem to work on Ubuntu 16.04 – user43326 Jun 14 '18 at 17:00
1

From my answer on Unix.SE, you can simply run,

echo "disable-screensaver=0" >> ~/.config/vlc/vlcrc

For more information see "When using VLC, why does my screen saver keep waking up?"

  • This has the same effect as the method in that answer, doesn't it? (It's no problem if it does -- different answers that work through the same underlying mechanism are totally fine -- but if it is somehow different, then I think it may be best to mention that.) – Eliah Kagan Apr 28 '18 at 14:28
  • 1
    I don't think so. My answer does so without using a GUI and I don't have to go digging around options. When the GUI answers stops working, my answer will prevail. =) – Evan Carroll Apr 28 '18 at 15:29
  • 2
    Here is the funny thing: even though I had "Disable screensaver" enabled in the GUI of VLC, I opened up my vlcrc file, and the line was commented out. I commented it in, saved, started VLC, and VLC is still failing to disable the screensaver. – Mike Nakis Jun 15 at 19:46
1

Expanding on this answer, one can type

xset s on; vlc; xset s off;

from a terminal to launch vlc, or write a bash script

#!/bin/bash
xset s on; vlc; xset s off;

or a desktop file whose command is something like

set s on; vlc %U; xset s off;

and set the association file/mimetype to it to open appropriate mimetypes. "%U" works for TDE, for other desktops, you might need to find the right syntax.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.