1

I´m building a new development machine and I need to setup Eclipse for C++ and PHP projects.

I´ve installed Ubuntu 15.10 and I started installing Eclipse Mars (4.5).

I choosed to use the new Eclipse installer, and did the installation of both packages (C++ and PHP) to the same location: /opt/eclipse. I want eclipse to be available to all users on that development machine.

Then I´ve build a symlink to call eclipse from anywhere using:

sudo ln -s /opt/eclipse/eclipse /usr/bin/eclipse

From my user console, when I type eclipse I´m getting the following error:

cox@dev1:~/projects$ eclipse
/root/.p2/poll/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.300.v20150602-1417: cannot open shared object file: Permission denied
Gtk-message: GtkDialog mapped without a transient parent. This is discouraged.


cox@dev1:~/projects$ sudo eclipse
Gtk-message: GtkDialog mapped without a transient parent. This is discouraged.

Clearly something is very wrong with my installation, so here are my questions:

a) Does C++ and PHP can be installed in the same folder ?

b) Is the /opt the correct place to install it - considering every machine user shall use eclipse ?

c) What would be the correct steps to install both packages of Eclipse ?

d) What is wrong with my installation ?

e) Is there an easy apt-get install command to install Eclipse Mars 4.5 on Ubuntu 15.10 ?

f) How can I fix my installation and let Eclipse run ?

Thanks for helping.

  • Did you download the tar.gz package from the website? – Raphael Nov 10 '15 at 5:28
  • Have you updated the installer before installing Eclipse? – A.B. Nov 10 '15 at 6:06
1

a) Does C++ and PHP can be installed in the same folder?

It is possible but you should use different sub-folders for the C++ and PHP distribution.

b) Is the /opt the correct place to install it - considering every user shall use eclipse?

Yes - this is the right place. But read point a)

c) What are the correct steps to install both packages of Eclipse?

The Eclipse installer is a good choice. Read this for installation steps and this for doing it manually with two different Eclipse distributions.

d) What is wrong with the installation?

If you did not upgrade the installer before installing and did not choose the expert mode of the installer and started the installer with sudo privileges the installer uses /root (if you do not change this explicit).

e) Is there an apt-get install command to install Eclipse Mars 4.5 on Ubuntu 15.10 ?

No - the Mars release has no PPA and does not exist in a Ubuntu repository.

f) How can I fix my installation to get Eclipse running ?

Move the plugin folder from the root folder to the correct place in /opt/eclipse and correct the permissions. The folder and its content should be readable by all users. But before you do that, read the last part of the answer...


  1. Remove the symbolic link in /usr/bin, use different desktop files, see the linked answers below.

  2. Remove the Eclipse installation in /opt.

  3. Remove the /root/.p2 folder. Nothing of any Eclipse distribution should be found there.

  4. Read this and this to become a feeling for the installation

  5. Use the expert mode in the Eclipse installer.

  6. Use different workspaces for PHP, C++, ... after the first start of the different Eclipse distribution.

  7. If it does not work perfectly remove everything and restart. It is important that the installation works perfectly to avoid problems when using Eclipse later.

  • Question: By "using the expert installer" you mean download the tar.xf files and install manually ? – Mendes Nov 10 '15 at 11:03
  • Question: I´ve used for a long time Eclipse 3.8, where a single eclipse command lauch eclipse for both C++ and PHP, depending on the workspace you open. Here you have a case where I will have 2 eclipse binary files, one on each directory.... Will I have 2 eclipses to open, one for C+ and one for PHP ? I´m confused... – Mendes Nov 10 '15 at 11:07
  • Question: What you mean by "update the installer", as it does not uses a apt-get update ? How to do it ? – Mendes Nov 10 '15 at 11:08
  • Read askubuntu.com/questions/695382/… – A.B. Nov 10 '15 at 11:09
  • The installation is fine now... I have questions around the 2 environments and I will post on a new thread.... Thanks for helping... – Mendes Nov 10 '15 at 12:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.