2

Problems:

1) Power management makes Wifi connection unstable. I need to disable it completely
2) My wifi doesn't automatically turns on after sleep. I should do it myself

Info

Laptop: Dell vostro 14-5480
OS: Ubuntu 15.04
kernel: 3.19.0-30
Wifi-card: Intel 7265
Wifi-driver: iwlwifi

What i've tried

"iwconfig wlan0 power off" helps but I should do it every time my Laptop turns on. I tried to play with /etc/pm. Nothing helped. The only solution was adding

sleep 10
iwconfig wlan0 poweroff
exit 0

to /etc/rc.local. Now power management turns off, as I need, but only when I reboot/switch on laptop. If I turn my wifi on manually after suspend, I should also manually turn off power management.

I thought maybe 13.10 suspend kills wifi connection solution might help, I made a file wakenet.sh, but it doesn't work and it shouldn't as ubuntu 15.04 doesn't have nmcli nm, so it's impossible to use

nmcli nm sleep flase
At least I haven't found how to do it with new nmcli.

Maybe someone can help me at least in finding the proper alternative command instead of nmcli nm sleep false?

  • Doesn't iwlwifi default to power:off? From modinfo iwlwifi: parm: power_save:enable WiFi power management (default: disable) (bool) – chili555 Nov 9 '15 at 15:14
  • I guess no, here is my output, when i try iwconfig pastebin.com/bMuyjVW3 – Sabine Nov 9 '15 at 15:24
  • What does this tell us? cat /sys/module/iwlwifi/parameters/power_save? We hope it is N. – chili555 Nov 9 '15 at 16:48
  • Yes, it says exactly "N" – Sabine Nov 10 '15 at 8:44
1

The best solution that worked for me (in Ubuntu 16.04LTS) is to change the value of wifi.powersave located in /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf from 3 (enabled) to 2 (disabled).

This effectively makes the effects of sudo iwconfig <interface> power off permanent.

Source: Power management for wireless unable to turn off in Xubunu 15.04 Vivid

0

there are a couple of options here:

How can I prevent iwconfig power management from being turned on?

The answer provided by Pierz worked for me:

Another approach is to add an explicit directive (wireless-power) to control power management in the /etc/network/interfaces configuration file (e.g. Disable it for wlan0 with DHCP):

auto wlan0 
iface wlan0 inet dhcp
wireless-power off

I am using:

OS: Ubuntu 16.04.1 LTS  OS 
image: ubuntu-16.04-preinstalled-server-armhf+raspi3.img

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.