1

In Ubuntu 14.04 LTS I used to MenuLibre application to create menu items for applications in Unity and Gnome desktop environments as an alternative to edit the text file .desktop of /usr/share/applications.

sudo apt-get install menulibre

MenuLibre screenshot with custom Nautilus Action

One of the customizations I did was create an action in Nautilus icon context menu "Open as Administrator" with the following lines in /usr/share/applications/nautilus.desktop, not the path of screenshot:

Actions=Window;Administrator;

[Desktop Action Window]
Name=Open a new window
Exec=nautilus --new-window
OnlyShowIn=Unity;

[Desktop Action Administrator]
Name=Open as Administrator
Exec=gksudo "nautilus --new-window"
OnlyShowIn=Unity;

Taking as its premise that the nautilus-actions extension is already installed by default, builtin in the Ubuntu.

apt-cache show nautilus-actions
apt-cache policy nautilus-actions

When I click the right mouse button on the "Files" icon, the Nautilus file manager, a drop down context menu was shown to the item "Open as Administrator".

However, in the version 15.10 Wily Werewolf, nothing happens, it seems to me that the nautilus-actions extension is being ignored by Nautilus 3.14.

Does anyone have any idea what might be happening?

PS: I know the nautilus-admin extension, but it is not installed by default in Ubuntu.

1

I found out the problem!

In all forms of launching the Nautilus application under the [Desktop Entry] tag has a instruction NoDisplay=true. This means that none of them are presented to the user in the Dash. The only icon that appears in the Dash, and consequently is present in Launcher, is generated automatic and dynamically by Nautilus.

cd /usr/share/applications 
ls -l nautilus*
-rw-r--r-- 1 root root 588 Nov 14 08:53 nautilus-autorun-software.desktop
-rw-r--r-- 1 root root 662 Nov 14 08:54 nautilus-classic.desktop
-rw-r--r-- 1 root root 549 Nov 14 08:55 nautilus-connect-server.desktop
-rw-r--r-- 1 root root 723 Dez  4 07:00 nautilus.desktop
-rw-r--r-- 1 root root 642 Nov 14 08:55 nautilus-folder-handler.desktop
-rw-r--r-- 1 root root 603 Dez  4 05:33 nautilus-home.desktop

For this reason it is that appears only a single icon "Files" in the Dash. When I deleted the instruction line NoDisplay=true of file nautilus.desktop, appeared two icons "Files" in the Dash. So I removed the icon "Files" of Launcher and dragged the second icon "Files" from Dash to the Launcher.

Eureka!

Now the drop down context menu of "Files" icon in the Launcher displays the option "Open as Administrator" of the [Desktop Action Administrator] tag.

The final configuration file "nautilus.desktop" was as follows:

[Desktop Entry]
Name=Files
Name[pt_BR]=Arquivos
Comment=Access and organize files
Comment[pt_BR]=Gerenciador de arquivos
Keywords=folder;manager;explore;disk;filesystem;
Exec=nautilus --new-window %U
Icon=system-file-manager
Terminal=false
Type=Application
StartupNotify=true
Categories=GNOME;GTK;Utility;Core;FileManager;
X-GNOME-Bugzilla-Bugzilla=GNOME
X-GNOME-Bugzilla-Product=nautilus
X-GNOME-Bugzilla-Component=general
X-GNOME-Bugzilla-Version=3.14.2
X-GNOME-UsesNotifications=true
X-Unity-IconBackgroundColor=#af4853
X-Ubuntu-Gettext-Domain=nautilus
Actions=Window;Administrator;

[Desktop Action Window]
Name=Open a new window
Name[pt_BR]=Abrir uma nova janela
Exec=nautilus --new-window
OnlyShowIn=Unity;

[Desktop Action Administrator]
Name=Open as Administrator
Name[pt_BR]=Abrir como Administrador
Exec=gksudo "nautilus --new-window"
OnlyShowIn=Unity;

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.