1

This question already has an answer here:

I have upgraded the kernel to linux 4.2.5-040205-generic,this problem will not cease to bug me

I am currently running my laptop on the nomodeset kernel parameter,and am not able to do anything worthwhile on my laptop

marked as duplicate by muru, Eric Carvalho, Elder Geek, Seth Mar 7 '17 at 2:06

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

try this, it worked for me on my Acer E5-511 (same problem on 15.10 and now 16.04). Soemthing to do with Intel power saving regime for laptops, I suspect. 4 days free of crashes (also no shutdown problems any more)

Ubuntu 15.10 freezes on Acer Aspire E11

0

I spent a day and a half getting my Aspire E5-511 to run any of 14.x, 15.x, 16.04 without freezing (sometimes during install.) Even when the system runs properly it never powers itself off properly on shutdown.

After much googling and experimentation, I found a fix - The kernel doesn't matter. The freeze can show up on about any kernel (including the old 4.1.12)

A few boot parameters will fix it completely.

You need to set:

  intel_idle.max_cstate=0
  processor.max_cstate=1
  modprobe.blacklist=dw_dmac,dw_dmac_core

If your system boots at all, edit /boot/grub/grub.cfg. Replace every occurence of :

quiet splash  --

With this:

quiet splash intel_idle.max_cstate=0 processor.max_cstate=1 modprobe.blacklist=dw_dmac,dw_dmac_core --

Now do:

sudo update-grub

Reboot and you should be good to go. If your system doesn't get this far - if it hangs while trying to boot up, do a fresh install. Here's a walkthrough (from Windows.):

I grabbed the 14.04 LTs 64-bit ISO file. The 64-bit version is key in that it supports the UEFI file system. I suspect this solution works for later releases, but haven't yet tried them.

I used Rufus http://www.techrepublic.com/article/pro-tip-use-rufus-to-create-a-bootable-usb-drive-to-install-almost-any-os/ to make a bootable thumb drive from the ISO file. (On windows, you might need to right-click the file and run as Administrator.) When it asks if you want to do a file-write (default) or a DD data dump, accept the default of file-write. This allows you to edit the file system on the thumb drive.

Open a file explorer, open the thumb drive, and locate the file boot/grub/grub.cfg. Now make sure File Explorer is set to "show file extension" (for instance, on Windows 10 - http://www.file-extensions.org/article/show-and-hide-file-extensions-in-windows-10. Google your OS if otherwise.)

Rename grub.cfg to grub.txt (right-click/Properties). Double-click the file and open with notepad.

Make the text substitutions described above.

Rename grub.txt back to grub.cfg.

Reboot. Hit F-12 to bring up boot menu. Boot from the thumb drive. You should get a working system now.

If your system hangs when trying to boot from the thumb-drive, you can add those boot parameters from the Grub menu. (Can someone knowledgeable give the instructions for this?)

Please excuse all the detail, I wanted to make this information accessible to the broadest possible set of users, given that it's a distro-killing extinction event of a bug on this class of hardware.

I'd be interested to hear if this works for later distros as well, I suspect it does (since they all failed in the same way.)

I also had some mouse problems till I went into BIOS and set Main/touch to Basic.

Not the answer you're looking for? Browse other questions tagged or ask your own question.