0

I have a disk partition named "LinuxAux" which I have always opened by clicking on it from the "Devices" list on the left tab of Nautilus.

Due to an accident, my laptop's battery ran out with LinuxAux mounted and when I rebooted it, after mounting the partition, the links to it were still broken. A new virtual device (not sure how to name it) called "LinuxAux1" has appeared in my /media/username/ folder and that one is the one that is mounted by Nautilus. It has the same content as what LinuxAux used to have so I redirected the links and everything works fine now.

However LinuxAux is still on /media/username/ and I'd like to mount it to see what's inside, know if it it occupying more space or if it's just some phantom image. But my knowledge of the mount command is poor and I definitely don't know how to use it in this situation.

Some (maybe) useful data:

  • OS: Ubuntu 14.04
  • When I boot the computer, the only thing that is in /media/username/ is an icon of a folder with a lock called LinuxAux. (not LinuxAux1)
  • On the left tab of Nautilus LinuxAux is listed, but it actually mounts LinuxAux1
0

Have you tried mounting partition using Disk application which is come along Ubuntu installation?

Open Disk, then click on your expected to be Linux Aux partition (perhaps it shows the Linux Aux label). Then choose more actions (on the below partition bar with 2 gears icon). Choose Mount options.

There you can set it to mount at autostart, show it in nautilus, and also set the Mount Points.

I think that's the easiest way.

  • It looks like no new partitions have appeared. There is, however, a difference on the amount of free space each partition has (specially in my main Linux partition) between what the Disk application shows and what Nautilus is telling me. Not sure if that is actually important. Also, I don't really know how /mnt works but Nautilus shows nothing there while Disk indicates that the mount point is there. – Jurcan Nov 9 '15 at 11:27
  • @Jurcan I prefer to mount my local drive partition in /mnt, while /media for usb (external drive). Try to redo your action in Disk application, then unmount your 'Linux Aux' if possible. Then try again your first try step. – adadion Nov 9 '15 at 11:33
  • So I disabled Automatic Mount Options for LinuxAux, tried to mount it and got the following error message <<Error mounting system-managed device /dev/sda8: Command-line `mount "/mnt/d7c193d9-ae07-4d7e-85f5-1f7a47af7077"' exited with non-zero exit status 32: mount: wrong fs type, bad option, bad superblock on /dev/sda8, missing codepage or helper program, or other error In some cases useful info is found in syslog - try dmesg | tail or so (udisks-error-quark, 0)>> – Jurcan Nov 9 '15 at 11:43
  • @Jurcan can you still access Linux Aux1 in nautilus? if yes, click on the path (at the upper) to see the parent folder to determine in which folder it's being mounted at. – adadion Nov 9 '15 at 12:32
  • After that, unmount that partition. Open Disk application again, don't set to Automatic Mount Options, then give checklist Mount at Startup, checklist on Show user interface. And make sure that it will show the configuration exactly look like these nosuid,nodev,nofail,x-gvfs-show above Mount point field. Then set your Mount Point, ex. /Mnt/Aux . Identify as /dev/disk/by-uuid/xxxxxx (depending on your partition uuid). Make sure the filesystem type are correct too. – adadion Nov 9 '15 at 12:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.