5

I am using Ubuntu 11.10 (Unity) as Guest/Host using VirtualBox. I don't want a Unity on login and want to directly get to a shell in the Guest after the boot. What changes have to be done?

  • Do you mean boot directly to a terminal shell? No GUI? – Bruno Pereira Dec 20 '11 at 0:19
1

Unity is a shell for Gnome. Unless you've setup automatic login, then Unity does not automatically start. Do you mean that you don't want to start the display manager, and get a commandline interface instead? In that case, simply remove lightdm and gdm. You can just reinstall it later if you want to.

  • Jo- you mean to remove lightdm and the gdm from the synaptic package manager? BTW, I am using Unity. – Praveen Sripati Oct 20 '11 at 15:24
  • Uninstalling an application will prevent it from starting, surely. If you're not going to use it, then removing it won't do any harm. – Jo-Erlend Schinstad Oct 20 '11 at 21:29
0

You can either tell lightdm or gdm (depending on which you use) not to load at start up, or you can tell upstart to boot into run level 3.

So either:

sudo update-rc.d -f lightdm remove

or

sudo update-rc.d -f gdm remove

or

sudo gedit /etc/inittab

and change the run level to 3

  • There is no '/etc/inittab' in 11.10. I ran the command 'telinit 3' and checked with 'runlevel'. Rebooted, but still logged into Unity and not into shell. – Praveen Sripati Oct 20 '11 at 11:25
0

If you don't want to use the GUI, installing the server version is the best option as it will only install the needed files.

If you want to use the GUI occasionally, Jo-Erlend Schinstad's answer, uninstalling *gdm is a great solution.

If for some reason you don't want to uninstall the gdm, then you can prevent it from running at boot editing your /etc/init/ligthdm.conf file, or the equivalent file if you are using another dm. Just change the line that reads:

start on ((filesystem
           and runlevel [!06]
           ...

to:

start on ((filesystem
           and runlevel [!0123456]
           ...

This condition will never met (the computer is always in one of those run-levels) and it will never start.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.