0

I am trying to install Pylot on my computer and am using the instructions from Pylots website. Their site asks you to install wxPython. When I try to from their provided resource I am getting thrown an error.

Here is Pylot's getting started guide: http://www.pylot.org/gettingstarted.html

It directs Linux users to install wxPython at number three on their list. I follow the resource they provide for installing wxPython (http://wiki.wxpython.org/InstallingOnUbuntuOrDebian) and get an error when I run their first line of code...

curl http://apt.wxwidgets.org/key.asc | sudo apt-key add -

This is the error I am thrown...

  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0curl: (6) Could not resolve host: apt.wxwidgets.org
gpg: no valid OpenPGP data found.

Can anyone help me get Pylot up and running? I am having a terrible time with it.

1

The hostname apt.wxwidgets.org is an invalid host.

$ host ping http://apt.wxwidgets.org/ 
host: couldn't get address for 'http://apt.wxwidgets.org/': not found

The latest supported Ubuntu version was Ubuntu 11.04.

Depending on your Ubuntu version, install python-wxgtk2.8 or python-wxgtk2.6 from the Ubuntu repositories:

sudo apt-get install python-wxgtk2.6

or

sudo apt-get install python-wxgtk2.8
  • It says that I already have 2.8 on my system. – Erik Åsland Nov 9 '15 at 15:05
  • Great, nothing to do for you – A.B. Nov 9 '15 at 15:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.