1

I'm on Ubuntu 14.04, and have Pinyin working as an input. However, I use the Dvorak layout and haven't been able to find a way to input Pinyin using the Dvorak layout - it defaults to QWERTY. Any ideas?

1

I had this problem until maybe 10 minutes ago. The way I solved this was to get rid of all keyboards layouts on the system except for EN-Dvorak and Pinyin.

This seems to solve the problem since ibus on pinyin mode specifies the default keyboard layout used on the system in "/usr/share/ibus/component/pinyin.xml"

<engine>
...
<layout>default</layout>
...
</engine>

If it can't find anything else other the dvorak then it is the default. I'm going to try adding EN-US back in now and see if it keeps dvorak as the default.

  • another option is to to just edit the EN-US keyboard files to match dvorak – William Dec 8 '18 at 16:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.