I've got a new installation on Compaq 6715b. I tried following these instructions to increase my screen's resolution.

What I did:

  1. Ran the command:

    sudo cvt 1680 1080 60
  2. Found out my device like this:

    xrandr -q

    And I got this:

    Screen 0: minimum 320 x 200, current 1280 x 800, maximum 8192 x 8192
    VGA-0 disconnected (normal left inverted right x axis y axis)
    LVDS connected primary 1280x800+0+0 (normal left inverted right x axis y axis) 331mm x 207mm
       1280x800       60.0*+
       1280x720       59.9  
       1152x768       59.8  
       1024x768       59.9  
       800x600        59.9  
       848x480        59.7  
       720x480        59.7  
       640x480        59.4  
    S-video disconnected (normal left inverted right x axis y axis)
  3. Then I typed this:

    sudo xrandr --newmode "1680x1080_60.00"  151.50  1680 1792 1968 2256  1080 1083 1093 1120 -hsync +vsync
  4. And then did this:

    sudo xrandr --addmode LVDS 1680x1080_60.00
  5. Finally, I got to the GUI and took display settings. I changed the resolution and my screen went crazy. Just one flat colour with no components. Only a few random squares.

I've searched and the task seems pretty challenging to me.

Is there an easy way to fix this?

Many thanks!


2 Answers 2


I'm not an expert on this, but I think you need to be sure you graphics card and screen both support the resolution you are trying to set.

Try this to test: xrandr --fb 1680x1080.

If the resolution doesn't change, your system doesn't support a bigger resolution than it is already set.

If it changes, it may change to a different resolution than expected. Check that by running xrandr and looking for the resolution:

LVDS connected primary WxH+0+0.

An apparent workaround would be to scale up your resolution with:

xrandr --output LVDS --scale-from 1680x1080

It is not the same (characters appear blurry) but it works.

  • 2
    See also askubuntu.com/questions/379123/…, especially the links to the bugs in my answer
    – Rmano
    Nov 11, 2015 at 21:12
  • Thanks for the answer. Here's what happens... trying the db line (first one) stretched the output and it looked blurred with parts of the screen cropped out. Even the clickable range was inaccurate. checking the resolutions listed the same things - no 1680x1080.
    – itsols
    Nov 12, 2015 at 4:47
  • I believe that the screen must support my expected resolution because that's what the specs say and with Windows, this is available.
    – itsols
    Nov 12, 2015 at 4:48
  • 1
    I've tried this: xrandr --output LVDS --fb 1680x1080 --panning 1680x1080 --scale-from 1680x1080 and it shows no change in the appearance but typing xrandr again shows that LVDS is 1680x1080. However, this is not listed in the set of resolutions, nor does it look any different.
    – itsols
    Nov 12, 2015 at 4:57
  • Sorry, I've misjudged the view. After the last command above (in my comment), it now spans the screen beyond the actual size. So I have to move the mouse to the right corner and the rest of the screen appears. I think we need to keep this within the physical screen size.
    – itsols
    Nov 12, 2015 at 5:03

Don't set the refresh rate in the cvt command; let your monitor do all the work:

cvt 1680 1080

You're using your monitor name as LVDS, but it would be a good idea to check what xrandr detects:

xrandr | grep " connected " | awk '{ print$1 }'

And last of all, don't use sudo!

  • Thank you for your time. I checked and yes, my screen is LVDS. I also tried the cvt command like you've mentioned but I don't see anything happening. Is there something else I'm expected to do after trying cvt? Thanks!
    – itsols
    Nov 13, 2015 at 12:33
  • @itsols yes of course - you need to add the output of cvt 1680 1080 - "1680x1080_60.00" 151.50 1680 1792 1968 2256 1080 1083 1093 - something like that to your xrandr commands
    – TellMeWhy
    Nov 13, 2015 at 12:36
  • I tried that but I had the same effect - I mean the screen goes into a weird colour flood like I mentioned in the question. Then after 30 seconds it's back to 1280x800.
    – itsols
    Nov 13, 2015 at 13:48
  • @itsols Have you tried extending your Ubuntu drivers? If Ubuntu doesn't support the resolution, it may be because that resolution size is not pre-installed on your system.
    – user454723
    Nov 14, 2015 at 21:43
  • @BorWal thanks for that thought... What do you mean by extending drivers ? When I go to drivers on the gui, I don't see anything to install. Could you please show me what I need to do?
    – itsols
    Nov 15, 2015 at 2:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.