1

Just installed Ubuntu 15.10 x64 a couple of days back; great by the way.

Apps locked to the launcher are lost after every restart; regardless of whether they are pinned by selecting Lock to Launcher or dragged from Dash.

How do I make them stick?

Also, Dash seems to have some hiccups as well, freezing from time to time.

5
  • Default apps or the manually added ones?
    – Raphael
    Nov 8 '15 at 3:04
  • The manually added ones. I've even created a .desktop entry for one in question.
    – iSofia
    Nov 8 '15 at 3:23
  • askubuntu.com/questions/316050/icons-disappear - Does this help?
    – Raphael
    Nov 8 '15 at 3:39
  • If you want any further details then comment and I will detail the above in an answer.
    – Raphael
    Nov 8 '15 at 3:45
  • Thanks for the suggestion, but it does not seem to work. I get this error: Traceback ... File "/usr/bin/unity" ... Import glib ... ImportError: No module named glib
    – iSofia
    Nov 8 '15 at 4:31
1
  1. Install glib using the command:

sudo apt-get install libglib2.0-0

EDIT: Also, it seems that you might need to install python gst:

sudo apt-get install python-gst*

  1. Log out of your system.
  2. Then press

Ctrl + Alt + F1

  1. Login with your Username & Password.

  2. Then, run this commands

unity --reset-icons

unity --reset

sudo reboot now

EDIT: If even still you are unable to lock items onto the launcher then, open Home then, press "Ctrl + h" to show hidden folders. Navigate to .config and move anything in the dconf folder to another directory(such as ~/dconf).

EDIT: Desktop file format:

[Desktop Entry] Name=AppName

Type=Application

Exec=/path/to/App/App %f

Terminal=false

MimeType=application/x-app

Icon=/path/to/App/App_icon.jpg

Comment=App comment

NoDisplay=false

Categories=app_category;

Name[en]=App

8
  • It seems that it's already installed, so the first apt-get function installed and updated nothing. Then I tried logging-off and performing the Unity resets, but with the same results.
    – iSofia
    Nov 8 '15 at 5:31
  • @iSofia Edited, see if it works now.
    – Raphael
    Nov 8 '15 at 5:39
  • I was able to install the python package, and then successfully reset Unity; but the apps are still not locking to the launcher. Same with manually installed apps and those installed by the Software Center.
    – iSofia
    Nov 8 '15 at 7:59
  • @iSofia Edited.
    – Raphael
    Nov 8 '15 at 9:05
  • I'd have to thank you for your tireless help. It appears that Software Center downloaded/installed apps are now able to be locked to the launcher. However, manually installed ones still don't; are there any setting that these must have in order to be locked? Perhaps I've done the .desktop file wrongly.
    – iSofia
    Nov 8 '15 at 9:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.