3

First off, let me say, I don't believe this to be a duplicate as I've tried everything I can find.

Last week, I started the upgrade process to Ubuntu 15.10 from 14.04. I did the upgrade to 15.04, which seemed to turn out fine. I could log in and use the computer, and nothing seemed to be missing. I then opened a terminal and started the upgrade to 15.10.

This also seemed to go well, occasionally confirming whether I wanted to replace some config files or whether I wanted to keep them as they were. Some were config files for fglrx, and I kept them the same. I don't think this is the problem, but I thought I'd include it.

So, the upgrade process finished and I answered "yes" to the reboot prompt. Now, here's where the problems started. The computer rebooted and the bootlogo showed up fine, but once it finished booting, I was left with a blank screen that would occasionally flash some text. I took a video of the screen so I could look at what the text said and none of it was useful.

Now, here's where I need to put some background in. I originally installed normal Ubuntu 14.04, with Unity and lightdm, then installed KDE on top of that. Because of KDE's Xorg memory leak problem, I ended up installing GNOME to get rid of it. I now had three desktop environments and had gdm in use instead of lighdm.

Back to the problem: Since I couldn't even get to the login screen, I decided to switch to lightdm to see if anything would happen. I managed to do this using a TTY and rebooted into lightdm, which showed up fine. I tried to login, but was instantly kicked back to the login screen. I made a new account through the terminal, but that didn't help.

I then went back to the TTY and proceeded to purge xserver-xorg and reinstall it, purge GNOME and reinstall it, purge Unity and reinstall it, and just purge KDE completely. Now, after all of this, when I try to login to either Unity or GNOME, I get a blank screen for a few seconds and then a "System Problem Detected" window. I can't see what the problem is as hitting Report does nothing and I eventually get kicked back to the login screen.

It almost seems like something is crashing so I get kicked back, but I can't figure out what. I can do a fresh install, but it would be much less of a hassle to be able to fix this, as I have configs everywhere that would need to be transferred.

Any suggestions (even dupe flags) are greatly appreciated. Sorry for the long question.

EDIT

My problems just kept getting worse until the computer finally wouldn't boot. It now just shows a blinking cursor and kills the keyboard no matter which option in GRUB I choose. I will leave this question here, but I've given up and am reinstalling. If you do have suggestions or answers, feel free to post them, as they may help others.

closed as off-topic by Seth Jan 28 '16 at 2:25

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Seth
If this question can be reworded to fit the rules in the help center, please edit the question.

  • You may have a hardware fault, which can be checked by running tests from the Utimate Boot CD (see ultimatebootcd.com). If this were the case though, you will still have problems when you reinstall. – Scooby-2 Nov 10 '15 at 22:52
  • @Scooby-2 I reinstalled already. Everything's fine now that I'm reconfigured. Thanks though. – TheWanderer Nov 10 '15 at 22:52