1

I have a Phillips TV hooked up to my computer via HDMI. The computer is running Xubuntu 15.10. If the TV turns off, when I turn it back on, the screen is blank - the computer is sending no signal. I have to manually restart the computer to get a visual again.

Prior to 15.10, when I had this issue, I could use the fix discussed here: Xubuntu 14.04 black screen after monitor off/on I have hotplug events disabled in my xorg.conf, and the optional configurations they mention I have also put in. Light locker is completely disabled, as is all power management options. These worked until I upgraded to 15.10 - now, even though those solutions are still in place, the issue has returned. Not sure what to do here, since everything else refers to 14.04, and those fixes are not making a difference here. :(

UPDATE

Here is some additional info, after trying one of the solutions below:

Output from xrandr --current while the screen is still on:

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 16384 x 16384
DVI-I-0 disconnected (normal left inverted right x axis y axis)
VGA-0 disconnected (normal left inverted right x axis y axis)
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected 1814x1020+0+0 (normal left inverted right x axis y axis) 0mm x 0mm panning 1920x1080+0+0
   1920x1080     60.00*+  59.94    29.97    24.00    23.97    60.00  
   1360x768      60.02  
   1280x768      59.99  
   1280x720      60.00    59.94  
   1024x768      60.00  
   800x600       60.32  
   720x480       59.94    60.05  
   640x480       59.94    59.93 

I tried using this command to restart the display:

xrandr --output HDMI-0 --mode 1814x1020+2+0 --pos 0x0 --rotate normal

by binding it to a hotkey using xbindkeys:

# Wake up the display
"xrandr --output HDMI-0 --mode 1814x1020+2+0 --pos 0x0 --rotate normal"
control+w
  • Any solutions? I have the same issue. Have a fresh install of xubuntu 15.10 and a Samsung TV plugged into HDMI of my GT 730. No errors/infos in syslog/dmesg/Xorg log etc. – prdatur Jan 6 '16 at 2:00
1

Ok I have found a "dirty" work around for this.

When having black screen do:

xrandr --output HDMI-0 --mode 1920x1080 --pos 0x0 --rotate normal --output VGA-0 --off

HDMI-0 = the output where your TV is connected 1920x1080 = The mode you want to have (desktop resolution) VGA-0 = other outputs which should be disconnected

To find your output name and supported modes do:

xrandr --current

This will give you a list of disconnected and connected outputs and their supported modes (for those who are connected).

But this is just a work around, not a solution in my optinion

  • This will not work for me - the screen is black, and it is the only screen, so I cannot see a command prompt in order to type those commands. I am in need of a configuration solution. – cidthecoatrack Jan 6 '16 at 12:28
  • You have multiple options to execute this command. It will work if you connected with vnc client (vnc server should be installed on the machine :P ) and from there you can enter the command or you could also assign this command as a hotkey and everytime the screen is black, press the hotkey. I know it is not a good solution, but better then rebooting :) – prdatur Jan 7 '16 at 12:39
  • I could not get the command to work - my display remained off. I updated the question with more information (too long for a comment). Please take a look and tell me if I've done something wrong, @prdatur – cidthecoatrack Jan 9 '16 at 14:44
  • Another update: the command worked when I was in a full-screen application (I was playing Portal), but does not work when the display is off. – cidthecoatrack Jan 10 '16 at 13:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.