0

I had ubuntu 14.04. tried upgrading to 15.04. all the files were downloaded and the upgrade process was started. some error messages showed up during installation but the upgrade process was finished. after that I tried restarting my computer, but clicking on restart or shutdown buttons didn't worked for me, so I turned off the computer by holding down the power button. but after turning it on again It didn't boot up and showed me the "Kernel Panic" problem. I tried booting up ubuntu in recovery mode with GRUB menu, but again the "kernel panic" problem.

As I'm posting this question, I'm using the ubuntu 14.04 live CD. I found that I can reinstall ubuntu without losing my files, but because I had upgraded to ubuntu 15.04, I can't use this option. it only allows me to install ubuntu 14.04 alongside ubuntu 15.04. if I do this, will I be able to access my old files and documents?

I currently managed to copy my /var/www folder from my internal 996 GB volume to my external hard drive, but it doesn't allow me to copy my documents, music, pictures which are stored in my /home directory. it says I have no permission. can I use terminal to change the permission of the folders in /home and copy them?

  • Is your home directory encrypted? – Captain Giraffe Nov 7 '15 at 10:53
  • no, it's not. @CaptainGiraffe – Agha Nov 7 '15 at 10:57
  • 1
    What are the current permissions? What is the output of ls -l /home/? – Captain Giraffe Nov 7 '15 at 11:15
  • try to sudo cp -r /mnt/home/agha /home/agha or change the permissions: sudo chmod -R a+w a+r /mnt/home/agha(I currently do not know, if a+w is needed) – LittleByBlue Nov 7 '15 at 11:18
  • 1
    or you could just to chroot into the 15.04 and fix the kernel. see help.ubuntu.com/community/BasicChroot – LittleByBlue Nov 7 '15 at 11:20
0

The easiest method for copying your data would be to open up terminal type in:

sudo nautilus

and then just copy the data to your external hardrive. I usually do it that way when I have to reinstall my Ubuntu installation.

Also don't worry about permissions, they should be alright once your system is reinstalled, if not, post a comment bellow and I'll tell you how to fix them.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.