0

Notebook is Lenovo IdeaPad Z500. Ubuntu 14.04 LTS with latest updates.

When I first time clicked on F12 (which change brightness up by default) light become lower, but not 0 (I see the text, but it's hard). And after that F11/F12 change values and scroll brightness but without effect.

In /sys/class/backlight/ I have only one folder - intel_backlight.

I tried different recipes:

  1. Edit /etc/default/grub and update-grub. Set GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor", I also tried set GRUB_CMDLINE_LINUX_DEFAULT="quiet splash intel_backlight=vendor"
  2. Setup "Brightness Controller". This program change brightness from current level to black monitor. And It thinks that max level is the same, which was before program installation, but it much lower than was origin.
  3. I tried edit files in /sys/class/backlight/intel_backlight/ like actual_brightness, brightness, max_brightness and I can't do that because of access permissions. When I changed permissions I got "Input/output error" and I can't save file too. Interesting that max_brightness has value = 976.
  4. I also tried make /usr/share/X11/xorg.conf.d/20-intel.conf file with no results.

No one of this recipes can help me

Of course I want

  1. Control brightness.
  2. Return max level brightness to my computer (because now is very low for human eyes)

I'm not experienced user in Linux. Please, help.

  • 1
    omgubuntu.co.uk/2013/04/brightness-control-ubuntu installing this might help i believe? have you checked the "dim screen to save power" checked in system settings -> brightness &lock? – biozalp Nov 7 '15 at 10:05
  • Oh, my god, my eyes tell you thank you, very much. In system settings -> brightness &lock was 0!!! If I try to set brightness to max monitor become black, but in the middle level it more than was before. – egorlitvinenko Nov 7 '15 at 10:09
  • making it a answer than, also the indicator i gave you works well i believe – biozalp Nov 7 '15 at 10:17
1

If that's the case make sure you take a look at system settings-> brightness & lock menu, unchecking the dim brightness and setting the brightness through that menu

  • You should add the link from your comment and explain it a bit more - that way the information remains if the link changes. Ping me, if you do. – KGIII Nov 7 '15 at 10:33
  • 1
    that's not the thing solved the issue, no need to include that – biozalp Nov 7 '15 at 11:19
  • Ah - missed that. Cool - then you get my upvote without adding it. Nice work. – KGIII Nov 7 '15 at 11:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.