0

I've been using 14.04LTS on my home server, including access via Windows Remote Desktop to the server itself as well as to several --type vrdp virtual box virtual machines. Now I've had to reinstall the server and I used the new Ubuntu 15.10, and the remote desktop access isn't working anymore, both to the server and to the virtual machines. It is not in the firewall, I can connect to the ports with telnet, but when I try to initialize a connection via the remote desktop software in Windows 7 to a virtual machine with RDP enabled in VirtualBox, it ends immediately with the "cannot connect to the remote computer" error. When I try to RDP into the Ubuntu 15.10 host itself, I get a xrdp login screen and when I enter credentials for the sesman-Xvnc module, I get the standard black/white dotted empty X screen with an X cursor for like 2-3 seconds, and then the connection terminates. For every such connection attempt, ~/.xsession-errors shows:

X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  109 (X_ChangeHosts)
  Value in failed request:  0x5
  Serial number of failed request:  6
  Current serial number in output stream:  8
localuser:ondrej being added to access control list
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  109 (X_ChangeHosts)
  Value in failed request:  0x5
  Serial number of failed request:  6
  Current serial number in output stream:  8
openConnection: connect: No such file or directory
cannot connect to brltty at :0

What did change between 14.04 and 15.10 that broke my server?

2
  • At the viewer end - is there a 'require encryption' set? Check the vino settings as well. I'm not connected at the moment so I can't check it and it's 0600 so my memory is fuzzy. Check those, disable the require encryption and let me know if it worked.
    – KGIII
    Nov 7 '15 at 10:57
  • Windows Remote Desktop Connection isn't nice enough to explicitly show a "require encryption" checkbox or something like that. However, I've tried also RDC on Android, which is also a RDP client. This one has some security settings, but no matter what I did the result was either inability to connect at all, or the same error as above in the question. I've expanded the error text to include all that's in ~/.xsession-errors. And what has got vino to do with it? I thought this uses xrdp->vnc->x.org?
    – Ondrej
    Nov 9 '15 at 20:17
0

Just a guess.... In ubuntu 15.10, the upstart "service" manager has been replaced by the systemd solution. Depending on how you have performed your installation, this might explain this situation

I would try to

  • remove/re-install xrdp package (from Ubuntu repository)
  • Check that alternate desktop has been installed properly (mate-desktop or xfce or the one you like
  • Configure the ~/.xsession file for the user that will be login into the box via remote desktop (if you have multiple users, each user will need to create this file)

Try to follow instructions found in this post as people report that it's working

Hope this help

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.