Still need some help or ideas even. After trying all suggestions from @Chil and @Dav see comments below (the @ sign signals them I've responded in some way to the question right? I still have the same problem.

I can "see" wireless networks but I can't connect. I have fresh results to the all in one wireless script at >http://paste.ubuntu.com/13206822>, perhaps someone can make sense of this for me and free me from the tripping hazard clinging to my laptop and dragging across the living room floor, down the hall and into the common room. Thanks, Desi

Thank you David Foerster for your review of my post and recommendation to review, "How do I get my Lenovo T61 to connect to a wireless network?" The solution for that issue is possibly restricted to Ubuntu 11.04 & 11.10 depending, I suppose, on the accuracy of the wording in that post, please correct me if otherwise. I did, in any event, try the recommendation but it did solve my problem.

I'm running Ubuntu 14.04, I installed with the Internal Network Adapter Boot disabled in the BIOS. USB's didn't work until I enabled the Internal Network Adapter. Wireless has never worked but did identify available wireless networks. Wired Connection works just fine.

I have tried for several hours over several days to load the drivers for the "Intel Pro/Wireless 4965 AG or AGN Kedron" wireless controller. (I'm new) Additionally when I installed Ubuntu I accidentally didn't select "allowing for proprietary drivers"

The additional drivers tab,(System Settings/Software & Updates/) is empty, the search comes up negative. I have since installed Ubuntu-extras thinking that would help. I discovered the iwlagn Driver on the Intel site and thought that my solution. I tried to remove the existing iwl4965 Driver and was only partially successful.

I was not confident I found the correct info on how to install the Driver recommended by Intel-they suggested adding the drivers directly to (libraries?) I need help cleaning up the mess I've made and installing the proper driver so I can finally have freedom from my Ethernet tether.

I would also like to undo the installation "error/choice" when I selected "no proprietary" drivers - if necessary. Here is some info based on what others have been advised to provide.

Scratch that I followed the recommendation the popped up as I tried to submit my question to run the Wired/Wireless all in One script. I'll will remove most of what I had intended as it is all replaced and more at:http://paste.ubuntu.com/13141481/

I hope you can help.

desi@desi-HP-Compaq-8510p:~$ cat /etc/lsb-release; uname -a
Linux desi-HP-Compaq-8510p 3.19.0-32-generic #37~14.04.1-Ubuntu SMP Thu Oct 22 09:41:40 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

desi@desi-HP-Compaq-8510p:~$ lspci -nnk | grep -iA2 net
00:19.0 Ethernet controller [0200]: Intel Corporation 82566MM Gigabit Network Connection [8086:1049] (rev 03)
Subsystem: Hewlett-Packard Company Device [103c:30c5]
Kernel driver in use: e1000e

10:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection [8086:4229] (rev 61)
Subsystem: Intel Corporation Device [8086:1000]

The following is why I believe I only partially uninstalled the wireless driver....

desi@desi-HP-Compaq-8510p:~$ cat /etc/modprobe.d/iwlwifi.conf
# /etc/modprobe.d/iwlwifi.conf
# iwlwifi will dyamically load either iwldvm or iwlmvm depending on the
# microcode file installed on the system.  When removing iwlwifi, first
# remove the iwl?vm module and then iwlwifi.
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211

I'm sure the all in one script will contain a more accurate assessment of my troubles than I was able to cobble together....so I removed several pages of additional info the recommended substitute All in One Script can be found at old link - paste_ubuntu_com/13141481/.

Thanks again for your consideration.

Desi ps. while going through the recommended wireless "solutions" I did the following....sudo apt-get install firmware-b43-installer ....now I realize that's for a broadcom chip set right? Can it be undone?

  • 3
    Possible duplicate of How do I get my Lenovo T61 to connect to a wireless network? Nov 7, 2015 at 9:41
  • 1
    channel 1 is the most crowded channel in your very congested area. You seriously need to set your router to broadcast over a different channel, preferably one that is not in use or won't interfere as much with your neighboring networks.
    – mchid
    Nov 20, 2015 at 6:49
  • 1
    there is nobody on channel 9, channel 9 is a good channel and make sure your router is not broadcasting "n only" and that it is broadcasting bg or you may need to enable wireless n on ubuntu.
    – mchid
    Nov 20, 2015 at 6:53
  • Can you be more specific about your connection issues? What exactly happens when you try to connect to your network? On the face of it, there doesn't seem to be anything wrong with your drivers or iwlwifi.conf file - and the device seems to be enabled and scanning plenty of access points. Nov 20, 2015 at 13:11
  • 1. The post suggested by davidfoerster as duplicate is relevant to <= 12.04 versions of Ubuntu, I'm running 14.04. please refrain from the easy "click to help" by up-voting that suggestion. 2. mchid thanks but I change channels regularly how should I enable "n" on Ubuntu? 3. @steeldriver I click on the "updown" connectivity arrows in the upper right hand corner of the desktop screen. + I can see available routers including mine, + I select my router, the wifi icon "pulses" for a bit. + Then nothing, no error, no connection just noting. Hope this helps.
    – dharamija
    Nov 20, 2015 at 22:17

1 Answer 1


First of all, the installation of firmware-b43-installer is inconsequential. It will do no harm and needn't be undone.

Second, the correct driver, iwl4965 is blacklisted, preventing it from loading on boot. Please open a terminal and do:

sudo gedit /etc/modprobe.d/blacklist.conf

Use nano, kate or leafpad if you don't have the text editor gedit. Remove the very last line which now reads: blacklist iwl4965. Proofread carefully, save and close the text editor.

Next, the contents of the file you quoted, /etc/modprobe.d/iwlwifi.conf, appear correct and are, in any case, not relevant to your troubles.

We see several attempts and failures to connect to your access point. Please carefully check the password. For example, ChiliPepper is not the same as chilipepper. Second, check the settings in the router. WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, you may have better connectivity with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz, although it is likely to affect N speeds. I also have better luck with a fixed channel, either 1, 6 or 11, rather than automatic channel selection. Also, be certain the router is not set to use N speeds only; auto B, G and N is preferred. After making these changes, reboot the router.

Next, I recommend that your regulatory domain be set explicitly. Check yours:

sudo iw reg get

If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2

gksudo gedit /etc/default/crda

Use nano or kate or leafpad if you don't have the text editor gedit. Of course, substitute your country code if not Iceland. Change the last line to read:


Proofread carefully, save and close the text editor.

Next, I'd set IPv6 to Ignore in Network Manager: http://docs.fedoraproject.org/en-US/Fedora/18/html/Installation_Guide/images/netconfig/network-connections-ipv6-ignore.png This example is for ethernet, but you want wireless.

If these changes do not help, please try:

sudo -i
echo "options iwl4965 11n_disable=1"  >  /etc/modprobe.d/iwl4965.conf

Reboot and tell us if there is any improvement.

EDIT: Network Manager will default to the usually faster and more secure ethernet if it is available. I notice that, when you ran the wireless_script, ethernet was connected. As we attempt to troubleshoot wireless, please be certain that the ethernet is detached.

We don't know much about why the wireless will not connect. Please look for clues here:

cat /var/log/syslog | grep -i network | tail -n25

Post the result here and give us the link: http://paste.ubuntu.com

Let's try to compile the very latest driver. Download this package to your desktop: https://www.kernel.org/pub/linux/kernel/projects/backports/2015/11/15/backports-20151115.tar.gz Right-click it and select 'Extract Here.' Now, back to the terminal:

sudo apt-get install linux-headers-generic build-essential
cd ~/Desktop/backports-20151115
make defconfig-wifi
sudo make install

Reboot and tell us if there is any improvement.

  • Thanks chili555 for your help, thanks too to KGIII for reformating my question ( I was unable to find a way to thank KGIII directly and would still like to). Chili I tried all of your suggestions, following your directions very carefully. I noticed after saving the changes using the gksudo gedit /etc/default/crda command, sudo iw reg get came back 00 - I rebooted and regdomain=US. Please help some more, I'd love to get this problem corrected and the journey is exposing me to more and more of what I seem to thoroughly enjoy. Desi ps. I can't find the command for the all in one script.
    – dharamija
    Nov 9, 2015 at 2:18
  • replacement comment for recent deletion @chili555 I figured out how to re-run the all-in-one script. I got clever and took a chance walking through posting a duplicate wireless question, I found the script language via the links as I did with my original question. Results of all in one can be found at (paste.ubuntu.com/13206822) Hopefully I understood the mini-Markdown formatting standards and all appropriate parties are notified. I'm back where I started from, I can see wireless networks, I just can't connect. desi
    – dharamija
    Nov 9, 2015 at 4:16
  • Please see my edit above.
    – chili555
    Nov 20, 2015 at 15:07
  • Step One: paste.ubuntu.com/13376938, installing newest drivers etc. in several hours.
    – dharamija
    Nov 20, 2015 at 23:04
  • 1
    Your paste shows a perfect connection to ethernet. We are interested in wireless. Next, your attempt to connect to a random encrypted network with a "bogus string" produces the correct expected behavior; that is, Network Manager asks again, implying that the password you provided is incorrect. What happens when you attempt to connect to your own network where the password is known? cat /var/log/syslog | grep -i network | tail -n25 Again, with the ethernet disconnected.
    – chili555
    Nov 21, 2015 at 21:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.