0

Decided to update my packages using update-manager, now unity launcher isn't working.

If force to launch Unity, this is what I am getting:

ilshod@small-camel:~$ unity &
[1] 2440
dilshod@small-camel:~$ unity-panel-service: no process found
dilshod@small-camel:~$ Checking if settings need to be migrated ...no
Checking if internal files need to be migrated ...no
Backend     : gconf
Integration : true
Profile     : unity
Adding plugins
Skipping upgrade com.canonical.unity.unity.01.upgrade
Skipping upgrade com.canonical.unity.unity.02.upgrade
Initializing core options...done
Initializing bailer options...done
Initializing detection options...done
I    nitializing composite options...done
Compiz (opengl) - Fatal: No valid GL extensions string found.
Compiz (bailer) - Info: Ensuring a shell for your session
Window manager warning: "" found in configuration database is not a valid value for keybinding "move_to_workspace_4"
Window manager warning: "" found in configuration database is not a valid value for keybinding "move_to_workspace_3"
Window manager warning: "" found in configuration database is not a valid value for keybinding "move_to_workspace_2"
Window manager warning: "" found in configuration database is not a valid value for keybinding "move_to_workspace_1"
Window manager warning: "" found in configuration database is not a valid value for keybinding "toggle_fullscreen"

If I run glxinfo, this is what I am getting:

dilshod@small-camel:~$ glxinfo 
name of display: :0.0
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  137 (NV-GLX)
  Minor opcode of failed request:  4 ()
  Resource id in failed request:  0x3400003
  Serial number of failed request:  32
  Current serial number in output stream:  32

Any help on this?

1

I resolved the issue by re-installing Nvidia drivers. For some reason, every time I update core packages I have to reinstall the video drivers. This time for some reason, I was made to believe I didn't have to because Nvidia logo was showing up when launching X.

| improve this answer | |
  • If I'm not mistaken, rebuilding Nvidia drivers was a must when upgrading Xorg and stuff. Now I don't know the current state of things, but I think they have improved. – Braiam Jan 8 '14 at 16:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.