3

nvidia-screen-tearing-problem

How do I eliminate screen tearing

Using Compton for tear-free compositing on XFCE or LXDE

I have tried those solutions and i am still getting terrible image tearing on the screen while scrolling though a web page. enter image description here

I have enabled Sync to VBlack and Allow Flipping in nvidia settings and added compton -b to start up.

enter image description here

output of sudo lspci | grep NVIDIA

01:00.0 VGA compatible controller: NVIDIA Corporation GT200 [GeForce GTX 260] (rev a1)

Driver in use. enter image description here

xorg.conf

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 331.20  (buildd@roseapple)  Mon Feb  3 15:07:22 UTC 2014

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "ViewSonic VA1926wSERIES"
    HorizSync       24.0 - 82.0
    VertRefresh     50.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 260"
    Option "Coolbits" "4"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "metamodes" "nvidia-auto-select +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Tearing will occur when using a web browser and using Ristretto image viewer all so tears as well. Video applications like game and flash videos are fine and have no tearing.

Image tearing will also happen in the file manager

  • Your screenshot and xorg.conf don't match... Screenshot says "version 340.93" but the configuration file says "version 331.20". Does that mean you have tried all earlier versions of nVidia drivers i.e. from 304.93, 304.128 etc.? – clearkimura Nov 7 '15 at 15:47
  • @clearkimura no i haven't tried other drivers. I think that is the version of the nvidia-settings not the driver. – Neil Nov 7 '15 at 23:36
  • Don't use compton because it is not necessarily tear-free. Have you tried these two cases: 1. Xfwm compositor ON + nvidia driver, 2. Xfwm compositor OFF + nvidia driver? What were the results? – clearkimura Nov 9 '15 at 7:17
  • @clearkimura no change. – Neil Nov 9 '15 at 8:03
  • @clearkimura There is no tearing on video playback. yes the tearing will occur when using a web browser and using Ristretto image viewer all so tears as well. Video applications like game and flash videos are fine and have no tearing. – Neil Nov 9 '15 at 9:04
3

I have solved my problem by forcing a full composition pipeline

using this command to test it

nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"

and I made the changes permanent by adding this command to Session and Startup

nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"

Solution was found in this wiki

Worked Well for my GTX260 running Xubuntu 14.04 :D

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.