0

The following are what I did:

  1. sudo apt-get install --install-recommends linux-generic-lts-utopic xserver-xorg-lts-utopic libqt5gui5 libgles1-mesa-lts-utopic libgles2-mesa-lts-utopic libgl1-mesa-glx-lts-utopic libgl1-mesa-glx-lts-utopic:i386 libglapi-mesa-lts-utopic:i386 libegl1-mesa-drivers-lts-utopic

Except it reported that it cannot locate dkms.conf, everything goes well.

  1. reboot
  2. sudo add-apt-repository ppa:xorg-edgers/ppa
  3. sudo apt-get update
  4. sudo apt-get install nvidia-346
  5. reboot

After that, I can find an application called "NVIDIA X Server Settings" in my application list, and everything looks normal in it. It can even show the tempature of my GPU.

But sudo lshw -C display still cannot show my nvidia GTX 850M (I have already enabled NVIDIA):

*-display
   description: 3D controller
   product: GM107M [GeForce GTX 850M]
   vendor: NVIDIA Corporation
   physical id: 0
   bus info: pci@0000:01:00.0
   version: a2
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list rom
   configuration: driver=nvidia latency=0
   resources: irq:55 memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:f7000000-f707ffff
*-display
   description: VGA compatible controller
   product: 4th Gen Core Processor Integrated Graphics Controller
   vendor: Intel Corporation
   physical id: 2
   bus info: pci@0000:00:02.0
   version: 06
   width: 64 bits
   clock: 33MHz
   capabilities: msi pm vga_controller bus_master cap_list rom
   configuration: driver=i915 latency=0
   resources: irq:52 memory:f7400000-f77fffff memory:d0000000-dfffffff ioport:f000(size=64)

EDIT:

I am not sure is there any problem in my question, I think maybe I need describe what I expect in more details. I think if the driver is installed successfully, after I sudo lshw -C display, the "VGA compatible controller" should also be nvidia one, but now it still is Intel Integrated one.

If I am correct, does anyone can tell me what should I do to make the VGA compatible controller to nvidia one. If I am wrong, how could I know whether my naughty GPU is running or not. Thanks a lot!!!

0

I found in 14.04 the only way to use the nvidia was to turn off the Intel card in the bios. There should be a disable option in there. From there, I suggest doing a re-install of ubuntu (if you have only just installed it) and install the nvidia drivers from there.

  • Thank you very much for your constructive suggestion. Actually I have installed this 14.04 LTS for a long time and re-installing currently may not be very practical since I am still using my Ubuntu for some tasks and I also don't want to disable the Intel card, because I still want to use it sometimes for power saving. – blaboon Nov 11 '15 at 13:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.