1

I've having some issues with getting resume from hibernate using systemd (swsusp) to work on a Lenovo IdeaPad Z510, running under Ubuntu 15.10 (issue was the same under prior versions of Ubuntu as well).

  • DOES: From a successfully-hibernated machine (journalctl confirms success), resume appears to generate a "dead screen" (black display, no apparent session or keyboard interaction, yet nothing in journalctl indicating display/session failure).

  • SHOULD: From hibernate, restore session from swap partition and allow user to continue session.

As a clue, if I set nomodeset in grub, line GRUB_CMDLINE_LINUX_DEFAULT, resume works consistently well, though the native graphics hardware is clearly disabled (Haswell HD Mobile 4400).

Given this, I suspect two possible issues that would be causing this problem:

In this later case, it sounds like the 4.3 kernel release may resolve at least this one possible reason for my resume issues.

But for now, I'm interested in better understanding the former case, as I want to check all of my assumptions as they relate to configuring systemd to successfully permit hibernate and resume.

To date, here's what I've done to configure my machine for hibernate/resume using systemd:

  1. In etc/default/grub, configure GRUB_CMDLINE_LINUX_DEFAULT to include the resume parameter, passing the UUID of the swap partition in question (i.e., resume=UUID=453f0121-505d-42d3-8dad-87f913e67ddc). My current GRUB_CMDLINE_LINUX_DEFAULT is GRUB_CMDLINE_LINUX_DEFAULT="quiet splash resume=UUID=453f0121-505d-42d3-8dad-87f913e67ddc"
  2. Run sudo update-grub
  3. Edit/confirm resume=UUID=453f0121-505d-42d3-8dad-87f913e67ddc entry in resume file located in /etc/initramfs
  4. Run sudo update-initramfs -u
  5. Edit /etc/systemd/logind.conf to set HandleLidSwitch=hibernate
  6. Run sudo service systemd-logind restart
  7. Reboot for good measure

Resume will consistently fail with no obvious (to me) errors indicating the reason for the resume failure.

So, my question to the forum is this:

What debugging tools, systemd information resources, and general understanding of how to troubleshoot what appears to be a video driver issue can you recommend?

I'm quite interested in solving this situation within the context of using systemd as a solution.

Thanks very much.

Rich

closed as off-topic by Jorge Castro, Eric Carvalho, Fabby, Kevin Bowen, TheWanderer Oct 17 '16 at 22:29

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Eric Carvalho, Fabby, Kevin Bowen, TheWanderer
If this question can be reworded to fit the rules in the help center, please edit the question.

2

I had the same issue on Ubuntu Gnome 16.04. The only solution I found at the time was updating the kernel. After update to 4.5.3-generic the problem was gone.

The how-to upgrade linux kernel is described here.

You can check your kernel version through terminal:

uname -r
1

I tried these options

acpi_osi=linux i915.enable_rc6=1 i915.lvds_downclock=1 i915.enable_fbc=1 pcie_aspm=force

and until now the problem seems to be gone

taken from this link

EDIT:

acpi_osi='!Windows 2012'

now I'm using this option and until now it works as it should be

EDIT

I'm not an expert but I have the same issue. My last attempt ( and it appears to be working ), I had removed acpi acpid and acpi_call packages .. I don't know if they are related to the problem .. but I am know using kernel 4.4.10 and the hibernation is working well.

  • @Baron... unfortunately this did not solve my immediate issue: I still demonstrate a failure to resume from hibernate with the switches (as an aside, I was a bit suspect, as they are primarily for managing power and have little to do with suspend/hibernate/resume). And, as noted by Pilot, I'm really interested in debugging tools for better understanding the context of my specific issue. – richbl Nov 27 '15 at 19:41
1

While I never did receive a good answer to the question about how best to troubleshoot hibernate issues on my laptop, I did finally install kernel 4.8 (via a fresh install of Ubuntu 16.10), and hibernate now does as expected.

Hope this helps folks with the same issues I had...

Not the answer you're looking for? Browse other questions tagged or ask your own question.