1

I've done a stupid mistake on Terminal preferences and now when i open it, it closes.

I managed to add a log-in set up when i access Terminal so it will ask me for sudo password. But i accidentally added a null "%00" character on the log-in command, and now every time i open the Terminal, it closes instantly.

I uninstalled gnome-terminal, and removed all possible temporary files, deleted ~/.gconf/gnome-terminal - and deleted all "gnome-terminal" existing files and folders. Then i reinstalled "gnome-terminal" via UXTerm, but still when i open it, it closes due to that log-in command i added. Now i don't know what to do to fix this problem. Can someone help me, please?

  • 2
    What do you mean by "add a log-in set up"? What exactly did you do? – steeldriver Nov 6 '15 at 20:46
  • @steeldriver I'm thinking he means an auto-execute command – RPiAwesomeness Nov 6 '15 at 20:53
  • You can access Terminal preferences and on "Command" set-up a log-in command, like "sudo -i". But when i was adding the command i added "null" because of a bug with my keyboard, and saved it. When i did that, is that the issue started. – user469451 Nov 6 '15 at 20:59
1

i've finally found my fix for this.

It's a terminal user issue where i ran a command for log in with terminal.

I fixed it with this command: gnome-terminal -x /bin/bash

Then fixed the log-in command. That's how i fixed the issue.

Anyways, thanks for the help.

0

Try giving this a go:

  1. Switch to TTY1 via Ctrl-Alt-F1`

  2. Log in to your user

  3. Run these commands:

    rm -r ~/.gconf/apps/gnome-terminal gconftools --recursive-unset /apps/gnome-terminal

Hopefully this will take care of it! Source

  • When i executed the first command i got a "No such file or directory" error, even after installed gnome-terminal and executed it. When executed the second command nothing appeared. When i ran gnome-terminal via UXTerm i got a theme parsing error: No such file or directory. And yeah, it's an user log-in issue. – user469451 Nov 6 '15 at 21:11
  • @AlejandroHabboGameAcevedo Hmm...dunno then :( I'll look around a bit more. – RPiAwesomeness Nov 6 '15 at 21:17
  • @AlejandroHabboGameAcevedo Can you post the output of cat ~/.profile? – RPiAwesomeness Nov 6 '15 at 21:26
  • I don't have a .profile folder – user469451 Nov 6 '15 at 21:37
  • @AlejandroHabboGameAcevedo I know, it's not a folder, it's a file. Glad you solved it though :) – RPiAwesomeness Nov 6 '15 at 21:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy