1

Okay so I have searched for answers for this for days now and haven't figured it out. I am running a mid 2010 mac pro (8 core Xeon E5620, 16gb RAM, ATI Radeon HD5870), Triple booting through rEFInd boot manager to OS X/Win 10/Ubuntu 15.10. All was working perfect with 15.04 until i upgraded to 15.10. Let me start with what normally happens and then I'll get into the problem.

What NORMALLY Happens:

  • I press the power button and I hear that awful apple chime.
  • Screen goes to light gray for a second (apple's version of a bios I guess)
  • Skips the Apple Splash and goes strait into the rEFInd boot manager.
  • From here, I can select which OS to boot up and I select Ubuntu (the non-grub option because I disabled grub to have a smoother boot)
  • OS loads fine.

Before a few days ago, everything worked out perfect whenever I would boot Ubuntu 15.04, even if I booted from Grub. I went ahead and did the upgrade to 15.10 when the option became available to me. Once it finished the upgrade process and had to reboot, that's where the problem started.

What Happens Now:

  • I press the Power button and I hear that awful apple chime.
  • Screen goes to light gray for a second.
  • Screen goes black for a little bit as it skips the rEFInd boot manager.
  • The Ubuntu purple color quickly fills the screen and the splash logo appears.
  • The little dots below the logo slowly all turn orange.
  • Then nothing happens (I even let it sit there for 8 hours once).

I have tried so many things but it seems like keyboard commands don't want to work. It's a good thing that I installed Ubuntu to it's own drive because in order to get to the boot manager, I have to pull the drive completely. Anybody have any input other than formatting? I would prefer to NOT lose all of my files and settings on the drive.

1

No help needed now that I figured out my own answer but this may be a good answer for anyone else looking.

It's as simple as rebooting to the target disk utility (holding alt) at startup, and once in OS X, rebless the startup disk to target rEFInd.

Once you have blessed the EFI location and booted to rEFInd boot manager, find the proper startup option that works for you. It may take a few tries, but that's about all it takes to work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.