3

How can I use PS3 Sixaxis gamepad on Ubuntu 15.10? I have tried different repos but I am always getting 404 not found.

2

5 Answers 5

5

The easiest way to do this is to compile it yourself. Here's how I managed to get it working on Ubuntu 15.10 Wily.

~/$ sudo apt-get install pyqt4-dev-tools git 
~/$ sudo apt-get install libusb-dev libjack-dev libbluetooth-dev pyqt4-dev-tools
~/$ cd Downloads
~/Downloads/$ git clone https://github.com/falkTX/qtsixa.git
~/Downloads/$ cd qtsixa
~/Downloads/qtsixa/$ make
~/Downloads/qtsixa/$ sudo make install

After that it should be installed, and you can use the qtsixa program to connect to your device via bluetooth. TO do so, first connect your six axis controller to your computer via usb, and then enter the command below

~/$ sudo sixpair

After that unplug the usb from the controller and run the next command to connect to your six axis controller via bluetooth.

~/$ sixad --start

You will be prompted to press the Playstation button on your controller, which you actually need to hold down for a few seconds. Finally if everything worked, your controller should rumble for a second and you should be good to go.

2
  • 2
    Also, if you're like me and don't ever plan on using it with JACK, you can disable the JACK requirements to avoid having to install packages that may mess up your sound configuration. Simply open the file "~/Downloads/qtsixa/utils/Makefile" and set "WANT_JACK" to "false". By doing this, you no longer have to install libjack-dev.
    – Tropcon
    Apr 24, 2016 at 4:10
  • Still works on 16.04 Xenial. If you are not using JACK, in addition to "WANT_JACK" set to "false", you can remove libjack-dev from the list of libs to install. ~/$ sudo apt-get install libusb-dev libjack-dev libbluetooth-dev pyqt4-dev-tools Aug 3, 2016 at 8:09
2

On Ubuntu 15.10/16.04 and Linux Mint 18, you can still use the QtSixA PPA, but specifying "vivid" as the Ubuntu version (15.04), since that was the last officially supported version. To do so, execute the following:

sudo add-apt-repository "deb http://ppa.launchpad.net/falk-t-j/qtsixa/ubuntu vivid main"
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 736E4F0B
sudo apt update
sudo apt install sixad

Note: as far as I can tell, the GUI based application is no longer useful, at least to detect and connect controllers through Bluetooth. Because of that, you need to use the command line-based applications, i.e. sixad and sixpair

Edit: Apparently and according to my tests, sixad starts automatically at boot, but doesn't work at all when that happens, having to stop it an re-start it to make it to work. To prevent sixad from being started at boot, you have to execute:

sudo sistemctl disable sixad

and, when you're going to use it, execute:

sudo sixad -s

of course, all the above is because QTSixA is no longer supported. The PS3 and PS4 controllers are supposed to work natively in Linux, but I still prefer to use it instead of the native support. I haven't be able to connect my PS3 controllers natively, and when I use QTSixA, I can do other things like specify the Bluetooth MAC address to be paired.

I think I will mail the developer to know if it's possible for him to resume the support. I believe that applying only small modifications, the project could work properly out-of-the-box. And, even without doing anything, the PPA could still work.

1

Run:

sudo add-apt-repository ppa:falk-t-j/qtsixa
sudo apt-get update
sudo apt-get install qtsixa

Connect with your USB : sixpair

Disconnect sixaxis from USB sixad -s

Press the PS button to connect via bluetooth.

Source

1
1

Recent add on when compiling from source:

  • The only repo that allowed me to connect two controllers at the same time was the fork of RetroPie: https://github.com/RetroPie/sixad
  • I experienced the problem that even when pairing went smooth, I got no data at /dev/input/js0. I could only solve that by using another Bluetooth dongle.

One more thing: Some tutorials write "Press PS key on the controller to connect". But I had to press and hold the key for 1-2 seconds.

Hope that helps if you experience issues.

1
  • Works on Ubuntu 16.04! May 10, 2017 at 2:21
0

Okay, I just got QtSixA working in Wily. You can download the .deb files from the links at http://qtsixa.sourceforge.net/ . Specifically http://sourceforge.net/projects/qtsixa/ .

Open the zip file and you'll find sixad_1.2.1-0ubuntu0+karmic1_.deb and qtsixa_1.2.1-0ubuntu0+karmic1_all.deb . According to the Readme, install the sixad .deb file for your architecture (my desktop uses the amd64 one, yours probably does too). Just double-click that file from the Archive Manager and it'll open up in the Ubuntu Software Center where you can install it.

Next do the same with qtsixa_1.2.1-0ubuntu0+karmic1_all.deb.

I've got my PS3 controller plugged in over USB and when I start QtSixA it has options for configuring the controller. When I hit the round PS button in the middle it starts Steam. So I guess it's working now.

Edit: After following this process I'm getting an error from dpkg on subsequent apt-get commands: dpkg: error processing package qtsixa (--configure) So there's still more to this than I've done so far.

1
  • Thing is that I dicovered that DS3 is working on wily without any drivers. It just lacks rumble :O Nov 8, 2015 at 13:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.